summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-18 13:01:48 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-18 13:02:03 +0200
commit26a91427d5e0f8a0fcc06c11ba181d537e96209a (patch)
tree853ce1e8d3feaabcd83b1f4c3f33356f119f0b98 /x11-misc
parentdev-python/pytz: Bump to 2018.4 (diff)
downloadgentoo-26a91427d5e0f8a0fcc06c11ba181d537e96209a.tar.gz
gentoo-26a91427d5e0f8a0fcc06c11ba181d537e96209a.tar.bz2
gentoo-26a91427d5e0f8a0fcc06c11ba181d537e96209a.zip
x11-misc/xdg-utils: Bump to version 1.1.3
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdg-utils/Manifest1
-rw-r--r--x11-misc/xdg-utils/xdg-utils-1.1.3.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/xdg-utils/Manifest b/x11-misc/xdg-utils/Manifest
index d83758d2e36d..ac46cf432072 100644
--- a/x11-misc/xdg-utils/Manifest
+++ b/x11-misc/xdg-utils/Manifest
@@ -1,2 +1,3 @@
DIST xdg-utils-1.1.1.tar.gz 295213 BLAKE2B c52bf6bb4d5e2cd2848b17dc4f478debe1d9d399a02f014d0507ed26330ce47ac77c047919fabffff06c3cc773fab6bd4744bcdd9338e0726aca8e690bb76c0a SHA512 6641b17daea7eecfee0d395e621dc42481582e505bff90a6df5eb0299ed2dca7a76520f000d9545a8424f06d41590382156a2e50f3d68d5c1ab825c268e90edb
DIST xdg-utils-1.1.2.tar.gz 296735 BLAKE2B 0d68fee2581075ca4b6beb0f7db77eee76d30afe8e8a3da904451f3c8e1a123f2fa2dc68aa15f7697f2ed532ffc14122cae308776b559c628751514e063ba11e SHA512 1927506065788b5f8bba8b0617a8ee585265342fa40c4b73000d320acd5909036daef94d49495b00982dbb67b7706b2f1ed949cb4cc519dfa534be2c1c8f74db
+DIST xdg-utils-1.1.3.tar.gz 297170 BLAKE2B bd281df73d8c966d11b502dd7ec88d96dbc9683503f54b043ae4842f146b6847bd3dd6902cf993771848d9fcb55d26d67f032af2b8aa0795a6d9855535e57d5b SHA512 d1f819a211eb4104a90dfdc6fedcb640fd46b15ccfc8762266f8f538c49d74cb00027b8c1af991fb2a200acb4379986ae375700e06a2aa08fb41a38f883acb3e
diff --git a/x11-misc/xdg-utils/xdg-utils-1.1.3.ebuild b/x11-misc/xdg-utils/xdg-utils-1.1.3.ebuild
new file mode 100644
index 000000000000..af9be47a61ba
--- /dev/null
+++ b/x11-misc/xdg-utils/xdg-utils-1.1.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Portland utils for cross-platform/cross-toolkit/cross-desktop interoperability"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xdg-utils/"
+#SRC_URI="https://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
+#SRC_URI="https://people.freedesktop.org/~rdieter/${PN}/${MY_P}.tar.gz
+# https://dev.gentoo.org/~ssuominen/${P}-patchset-1.tar.xz"
+SRC_URI="https://portland.freedesktop.org/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="
+ dev-util/desktop-file-utils
+ dev-perl/File-MimeInfo
+ dev-perl/Net-DBus
+ dev-perl/X11-Protocol
+ sys-apps/dbus
+ x11-misc/shared-mime-info
+ x11-apps/xprop
+ x11-apps/xset
+"
+DEPEND=">=app-text/xmlto-0.0.26-r1[text(+)]"
+
+DOCS=( README RELEASE_NOTES TODO ) # ChangeLog is bogus, see git instead
+
+RESTRICT="test" # Disabled because of sandbox violation(s)
+
+#S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ # If you choose to do git snapshot instead of patchset, you need to remember
+ # to run `autoconf` in ./ and `make scripts-clean` in ./scripts/ to refresh
+ # all the files
+ if [[ -d "${WORKDIR}/patch" ]]; then
+ eapply patch
+ fi
+ eautoreconf
+
+ if pushd scripts &>/dev/null ; then
+ make scripts-clean
+ popd &>/dev/null
+ fi
+}
+
+src_configure() {
+ export ac_cv_path_XMLTO="$(type -P xmlto) --skip-validation" #502166
+ default
+}
+
+src_install() {
+ default
+
+ newdoc scripts/xsl/README README.xsl
+ use doc && dodoc -r scripts/html
+
+ # Install default XDG_DATA_DIRS, bug #264647
+ echo XDG_DATA_DIRS=\"${EPREFIX}/usr/local/share\" > 30xdg-data-local
+ echo 'COLON_SEPARATED="XDG_DATA_DIRS XDG_CONFIG_DIRS"' >> 30xdg-data-local
+ doenvd 30xdg-data-local
+
+ echo XDG_DATA_DIRS=\"${EPREFIX}/usr/share\" > 90xdg-data-base
+ echo XDG_CONFIG_DIRS=\"${EPREFIX}/etc/xdg\" >> 90xdg-data-base
+ doenvd 90xdg-data-base
+}
+
+pkg_postinst() {
+ [[ -x $(type -P gtk-update-icon-cache) ]] \
+ || elog "Install x11-libs/gtk+:2 for the gtk-update-icon-cache command."
+}