summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-06-08 09:44:22 -0500
committerBen Kohler <bkohler@gentoo.org>2021-06-08 09:44:36 -0500
commit2ddd26f1e9849014ce2ed03415df86f055dfc7f3 (patch)
tree75e5b735ae84c654a3d04d07e78fc072bc3d0419 /x11-misc
parentnet-misc/dhcp: Security cleanup (diff)
downloadgentoo-2ddd26f1e9849014ce2ed03415df86f055dfc7f3.tar.gz
gentoo-2ddd26f1e9849014ce2ed03415df86f055dfc7f3.tar.bz2
gentoo-2ddd26f1e9849014ce2ed03415df86f055dfc7f3.zip
x11-misc/i3blocks-contrib: fix direct gcc call
Closes: https://bugs.gentoo.org/794919 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/i3blocks-contrib/files/i3blocks-contrib-2.0.0-respect-CFLAGS.patch10
-rw-r--r--x11-misc/i3blocks-contrib/i3blocks-contrib-2.0.0.ebuild7
2 files changed, 16 insertions, 1 deletions
diff --git a/x11-misc/i3blocks-contrib/files/i3blocks-contrib-2.0.0-respect-CFLAGS.patch b/x11-misc/i3blocks-contrib/files/i3blocks-contrib-2.0.0-respect-CFLAGS.patch
index da72ecd10d81..764cd4b2b73c 100644
--- a/x11-misc/i3blocks-contrib/files/i3blocks-contrib-2.0.0-respect-CFLAGS.patch
+++ b/x11-misc/i3blocks-contrib/files/i3blocks-contrib-2.0.0-respect-CFLAGS.patch
@@ -10,6 +10,16 @@
$(P): $(OBJECTS)
--- a/brightness/Makefile
+++ b/brightness/Makefile
+@@ -1,6 +1,6 @@
+-CC=gcc
+-AS=as
+-LD=ld
++CC ?= gcc
++AS ?= as
++LD ?= ld
+ OBJDUMP=objdump
+ OBJCOPY=objcopy
+ SIZE=size
@@ -16,14 +16,14 @@
PRG = brightness
diff --git a/x11-misc/i3blocks-contrib/i3blocks-contrib-2.0.0.ebuild b/x11-misc/i3blocks-contrib/i3blocks-contrib-2.0.0.ebuild
index 51f71d6cbffa..88dab674b534 100644
--- a/x11-misc/i3blocks-contrib/i3blocks-contrib-2.0.0.ebuild
+++ b/x11-misc/i3blocks-contrib/i3blocks-contrib-2.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit optfeature
+inherit optfeature toolchain-funcs
DESCRIPTION="A set of scripts for i3blocks, contributed by the community"
HOMEPAGE="https://github.com/vivien/i3blocks-contrib"
@@ -24,6 +24,11 @@ src_prepare() {
default
}
+src_compile() {
+ tc-export AR CC LD
+ default
+}
+
src_install() {
emake DESTDIR="${D}" PREFIX=/usr install
}