summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-05-04 15:19:25 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-05-04 16:55:38 +0200
commit2e19c9194cfa6ed199bc31345f8ea65ae166f1b4 (patch)
tree5c3b5839c27806aae74321fa748d0227a12e8b36 /x11-misc
parentgui-apps/lavalauncher: sync live ebuild (diff)
downloadgentoo-2e19c9194cfa6ed199bc31345f8ea65ae166f1b4.tar.gz
gentoo-2e19c9194cfa6ed199bc31345f8ea65ae166f1b4.tar.bz2
gentoo-2e19c9194cfa6ed199bc31345f8ea65ae166f1b4.zip
x11-misc/xplanet: Don't call AR directly
Closes: https://bugs.gentoo.org/726292 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/20680 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xplanet/xplanet-1.3.1-r2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11-misc/xplanet/xplanet-1.3.1-r2.ebuild b/x11-misc/xplanet/xplanet-1.3.1-r2.ebuild
index 1eef6008ea98..ac79390deb72 100644
--- a/x11-misc/xplanet/xplanet-1.3.1-r2.ebuild
+++ b/x11-misc/xplanet/xplanet-1.3.1-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools flag-o-matic
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="Render images of the earth into the X root window"
HOMEPAGE="http://xplanet.sourceforge.net/"
@@ -66,3 +66,7 @@ src_configure() {
)
econf --with-cspice=no "${myconf[@]}"
}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}