summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-08-23 23:48:12 -0600
committerTim Harder <radhermit@gentoo.org>2019-08-23 23:50:46 -0600
commit4c87381169e5da96cc195675eeb651da005ca54a (patch)
treedd31be621c4d21dfaa3404a5d736849d3c4df724 /x11-misc
parentdev-libs/efl: clean old (diff)
downloadgentoo-4c87381169e5da96cc195675eeb651da005ca54a.tar.gz
gentoo-4c87381169e5da96cc195675eeb651da005ca54a.tar.bz2
gentoo-4c87381169e5da96cc195675eeb651da005ca54a.zip
x11-misc/sxhkd: version bump to 0.6.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/sxhkd/Manifest1
-rw-r--r--x11-misc/sxhkd/sxhkd-0.6.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/sxhkd/Manifest b/x11-misc/sxhkd/Manifest
index ceaaf277891a..4fc9dce06ff3 100644
--- a/x11-misc/sxhkd/Manifest
+++ b/x11-misc/sxhkd/Manifest
@@ -1,2 +1,3 @@
DIST sxhkd-0.5.9.tar.gz 34649 BLAKE2B e07d9a7a99cd3ab1436ece589a57023de87c6a1e74ef509e9bfc9db3bcda9680f826dc2edad1474004775cf307b9280dc60e18060a803deb801022c004bf0e8c SHA512 32ee7261b4fa10d5a62a7fa61e689977d12afd654e81123711bda1f006e4b6baa7524352086037594e6ef1989dd8fcb6eddc1114085ee91546a69f6d1146924e
DIST sxhkd-0.6.0.tar.gz 34756 BLAKE2B e0bf9cc50893baa345ea0dcfae096b5f76408bf1c5e8b5405a2175f33c6201c14c3683da2202cc2a9eaa07327df484f921863178b464164cdf931ca3a0c21848 SHA512 0ccafa2b29b87dcf6bdcb45b67b8aeb5f70c2855fe99c0cd2b271052cd7b6bbf5186b3ae2da3ae9b411f0766a8ab85a35b3a325442a80527a7c959280d36b46b
+DIST sxhkd-0.6.1.tar.gz 34808 BLAKE2B b25ff934d0a7f28b3950152ef800da90c5f990f2efd92e9178fef8a77939dc1ed1bbde55bb5a990c33fd3d0be7490dfb2e799ca56abf3c3c6f20c258169eb100 SHA512 d8cd6166ff7e7bc800ed79c5d63cbdfad4f9824c5a5e19b6a315b2ec570295150600651376265932f5fde8b6127f629a553337c6454a1c78c62b3395aaeb55a2
diff --git a/x11-misc/sxhkd/sxhkd-0.6.1.ebuild b/x11-misc/sxhkd/sxhkd-0.6.1.ebuild
new file mode 100644
index 000000000000..72d597e89864
--- /dev/null
+++ b/x11-misc/sxhkd/sxhkd-0.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Simple X hotkey daemon"
+HOMEPAGE="https://github.com/baskerville/sxhkd/"
+SRC_URI="https://github.com/baskerville/sxhkd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libxcb
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}
+ x11-libs/xcb-util"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+ systemd_dounit contrib/systemd/${PN}.service
+}