summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-03-15 14:26:23 +0100
committerJeroen Roovers <jer@gentoo.org>2019-03-15 14:26:35 +0100
commit524deaa55c22ed4c235d8027267a0a00469593da (patch)
tree5976b78767dd843624cf105c8a65e16890daef86 /x11-misc
parentsys-apps/sysvinit: Do not force -fstack-protector-strong. (diff)
downloadgentoo-524deaa55c22ed4c235d8027267a0a00469593da.tar.gz
gentoo-524deaa55c22ed4c235d8027267a0a00469593da.tar.bz2
gentoo-524deaa55c22ed4c235d8027267a0a00469593da.zip
x11-misc/dmenu: Update live ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dmenu/dmenu-4.9.ebuild1
-rw-r--r--x11-misc/dmenu/dmenu-9999.ebuild24
2 files changed, 13 insertions, 12 deletions
diff --git a/x11-misc/dmenu/dmenu-4.9.ebuild b/x11-misc/dmenu/dmenu-4.9.ebuild
index 9fe6efe17530..dafe23ddeda1 100644
--- a/x11-misc/dmenu/dmenu-4.9.ebuild
+++ b/x11-misc/dmenu/dmenu-4.9.ebuild
@@ -32,7 +32,6 @@ src_prepare() {
sed -i \
-e 's|^ @| |g' \
- -e 's|${CC} -o|$(CC) $(CFLAGS) -o|g' \
-e '/^ echo/d' \
Makefile || die
diff --git a/x11-misc/dmenu/dmenu-9999.ebuild b/x11-misc/dmenu/dmenu-9999.ebuild
index 8001b06f1d66..ac2f60df320b 100644
--- a/x11-misc/dmenu/dmenu-9999.ebuild
+++ b/x11-misc/dmenu/dmenu-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 savedconfig toolchain-funcs
DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
@@ -32,7 +32,6 @@ src_prepare() {
sed -i \
-e 's|^ @| |g' \
- -e 's|${CC} -o|$(CC) $(CFLAGS) -o|g' \
-e '/^ echo/d' \
Makefile || die
@@ -41,15 +40,18 @@ src_prepare() {
src_compile() {
emake CC=$(tc-getCC) \
- INCS=" \
- $(usex xinerama "-DXINERAMA" '') \
- $(
- $(tc-getPKG_CONFIG) --cflags fontconfig freetype2 x11 xft $(usex xinerama xinerama '')
- )" \
- LIBS=" \
- $(
- $(tc-getPKG_CONFIG) --libs fontconfig x11 xft $(usex xinerama xinerama '')
- )"
+ "FREETYPEINC=$( $(tc-getPKG_CONFIG) --cflags x11 fontconfig xft 2>/dev/null )" \
+ "FREETYPELIBS=$( $(tc-getPKG_CONFIG) --libs x11 fontconfig xft 2>/dev/null )" \
+ "X11INC=$( $(tc-getPKG_CONFIG) --cflags x11 2>/dev/null )" \
+ "X11LIB=$( $(tc-getPKG_CONFIG) --libs x11 2>/dev/null )" \
+ "XINERAMAFLAGS=$(
+ usex xinerama "-DXINERAMA $(
+ $(tc-getPKG_CONFIG) --cflags xinerama 2>/dev/null
+ )" ''
+ )" \
+ "XINERAMALIBS=$(
+ usex xinerama "$( $(tc-getPKG_CONFIG) --libs xinerama 2>/dev/null)" ''
+ )"
}
src_install() {