summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-03-14 11:17:28 +0100
committerJeroen Roovers <jer@gentoo.org>2019-03-14 11:18:00 +0100
commit550b51e97fdf516c4fe1a212f4ff3345993e1faf (patch)
tree7babfe38fb0194a612a714019ab9fa07484db1a6 /x11-misc
parentgnome-base/gnome-core-apps: bump to 3.30.2 (diff)
downloadgentoo-550b51e97fdf516c4fe1a212f4ff3345993e1faf.tar.gz
gentoo-550b51e97fdf516c4fe1a212f4ff3345993e1faf.tar.bz2
gentoo-550b51e97fdf516c4fe1a212f4ff3345993e1faf.zip
x11-misc/sisctrl: Configure for correct libdir
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Fixes: https://bugs.gentoo.org/680272 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild b/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild
new file mode 100644
index 000000000000..53c9511c8cc6
--- /dev/null
+++ b/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="tool that allows you to tune SiS drivers from X"
+HOMEPAGE="http://www.winischhofer.net/linuxsispart1.shtml#sisctrl"
+SRC_URI="http://www.winischhofer.net/sis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libXrender
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+DOCS="AUTHORS ChangeLog NEWS README"
+PATCHES=(
+ "${FILESDIR}"/${P}-no-xv.patch
+)
+
+src_configure() {
+ append-libs -lm
+ econf \
+ --with-xv-path="${EROOT}/usr/$(get_libdir)"
+}