summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-08 19:26:48 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-09 22:52:29 +0100
commit6a5aa20a393554ccb990acbce215513cceb908ba (patch)
treef31ad5fa7a15025890a3368e161b4bb304e5770d /x11-misc
parentx11-misc/tintwizard: EAPI bump 3 -> 6, migrate to python-single-r1 (diff)
downloadgentoo-6a5aa20a393554ccb990acbce215513cceb908ba.tar.gz
gentoo-6a5aa20a393554ccb990acbce215513cceb908ba.tar.bz2
gentoo-6a5aa20a393554ccb990acbce215513cceb908ba.zip
x11-misc/wbarconf: EAPI bump 4 -> 6, migrate to python-single-r1
Fixes: https://bugs.gentoo.org/599774 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3884
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/wbarconf/wbarconf-0.7.2.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/wbarconf/wbarconf-0.7.2.2-r2.ebuild b/x11-misc/wbarconf/wbarconf-0.7.2.2-r2.ebuild
new file mode 100644
index 000000000000..ac17c85bb707
--- /dev/null
+++ b/x11-misc/wbarconf/wbarconf-0.7.2.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Configuration GUI for x11-misc/wbar"
+HOMEPAGE="http://koti.kapsi.fi/ighea/wbarconf/"
+SRC_URI="http://koti.kapsi.fi/ighea/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="sys-devel/gettext"
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=x11-misc/wbar-1.3.3
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${P}-install.patch )
+
+src_install() {
+ ./install.sh "${ED%/}/usr" || die "./install.sh failed."
+ python_doscript wbarconf
+}