summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-01 13:42:38 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-01 13:42:38 +0100
commit801a0bd95271ec8dd369ba92593d83517b6a7825 (patch)
tree0d5a504760a5b3a6f1781f9b229c1c0a5f65b06d /x11-misc
parentmail-client/novell-groupwise-client: Fix symlink, RESTRICT (bug 542212), hash... (diff)
downloadgentoo-801a0bd95271ec8dd369ba92593d83517b6a7825.tar.gz
gentoo-801a0bd95271ec8dd369ba92593d83517b6a7825.tar.bz2
gentoo-801a0bd95271ec8dd369ba92593d83517b6a7825.zip
x11-misc/slop: Add live ebuild
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/slop/slop-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/slop/slop-9999.ebuild b/x11-misc/slop/slop-9999.ebuild
new file mode 100644
index 000000000000..4aef7f894258
--- /dev/null
+++ b/x11-misc/slop/slop-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An application that queries the user for a selection for printing"
+HOMEPAGE="https://github.com/naelstrof/slop"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/slop.git"
+else
+ SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="opengl"
+
+RDEPEND="
+ dev-libs/icu:=
+ x11-libs/libX11
+ x11-libs/libXext
+ opengl? (
+ media-libs/glew:0=
+ virtual/opengl
+ x11-libs/libXrender:=
+ )"
+DEPEND="
+ ${RDEPEND}
+ media-libs/glm"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSLOP_OPENGL=$(usex opengl)
+ )
+ cmake-utils_src_configure
+}