summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:19:06 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:09 +0100
commit87af2cef04225bf0ec5ec932892290caac13ff8e (patch)
treeb3ecacc03759bffcb3e1399abf875c30f8cb3403 /x11-misc
parentsys-fs/mhddfs: respect PKG_CONFIG (diff)
downloadgentoo-87af2cef04225bf0ec5ec932892290caac13ff8e.tar.gz
gentoo-87af2cef04225bf0ec5ec932892290caac13ff8e.tar.bz2
gentoo-87af2cef04225bf0ec5ec932892290caac13ff8e.zip
x11-misc/chgres: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/chgres/chgres-0.1-r2.ebuild8
-rw-r--r--x11-misc/chgres/files/chgres-0.1-flags.patch8
2 files changed, 9 insertions, 7 deletions
diff --git a/x11-misc/chgres/chgres-0.1-r2.ebuild b/x11-misc/chgres/chgres-0.1-r2.ebuild
index af5228d50ea5..34ce121d6578 100644
--- a/x11-misc/chgres/chgres-0.1-r2.ebuild
+++ b/x11-misc/chgres/chgres-0.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,13 +19,15 @@ RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXxf86vm"
DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+ x11-base/xorg-proto
+ virtual/pkgconfig
+"
PATCHES=( "${FILESDIR}"/${P}-{flags,includes}.patch )
src_prepare() {
default
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_install() {
diff --git a/x11-misc/chgres/files/chgres-0.1-flags.patch b/x11-misc/chgres/files/chgres-0.1-flags.patch
index 4045175dde09..74c37d7f101b 100644
--- a/x11-misc/chgres/files/chgres-0.1-flags.patch
+++ b/x11-misc/chgres/files/chgres-0.1-flags.patch
@@ -1,10 +1,10 @@
---- a/Makefile 2001-04-18 23:07:56.000000000 +0200
-+++ b/Makefile 2010-09-17 03:08:55.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -1,9 +1,9 @@
-CFLAGS=
-LDFLAGS= -L/usr/X11R6/lib -lXext -lX11 -lXxf86vm -lXxf86dga
-+LIBS= $(shell pkg-config --libs xext x11 xxf86vm xxf86dga)
-+INCLUDES= $(shell pkg-config --cflags xext x11 xxf86vm xxf86dga)
++LIBS= $(shell ${PKG_CONFIG} --libs xext x11 xxf86vm xxf86dga)
++INCLUDES= $(shell ${PKG_CONFIG} --cflags xext x11 xxf86vm xxf86dga)
prefix=/usr
chgres: chgres.o