summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:56:33 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:19 +0100
commit96a1a91090d23c7c05e3afcedc136d2823bc0057 (patch)
tree6b178ae316aaa781733ee306a181ca759b79e3fb /x11-misc
parentwww-client/surf: tidy up patches (diff)
downloadgentoo-96a1a91090d23c7c05e3afcedc136d2823bc0057.tar.gz
gentoo-96a1a91090d23c7c05e3afcedc136d2823bc0057.tar.bz2
gentoo-96a1a91090d23c7c05e3afcedc136d2823bc0057.zip
x11-misc/apwal: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/apwal/apwal-0.4.5-r2.ebuild25
-rw-r--r--x11-misc/apwal/files/apwal-0.4.5-makefile.patch4
2 files changed, 17 insertions, 12 deletions
diff --git a/x11-misc/apwal/apwal-0.4.5-r2.ebuild b/x11-misc/apwal/apwal-0.4.5-r2.ebuild
index 90f5f0196d25..766c3ed8f76c 100644
--- a/x11-misc/apwal/apwal-0.4.5-r2.ebuild
+++ b/x11-misc/apwal/apwal-0.4.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,22 +8,27 @@ inherit toolchain-funcs
DESCRIPTION="A simple application launcher and combined editor"
HOMEPAGE="http://apwal.free.fr/"
SRC_URI="http://apwal.free.fr/download/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-RDEPEND="x11-libs/gtk+:2
- x11-libs/gdk-pixbuf
+RDEPEND="
dev-libs/libxml2
- dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
-PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-S=${WORKDIR}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+)
src_configure() {
- tc-export CC
+ tc-export CC PKG_CONFIG
}
diff --git a/x11-misc/apwal/files/apwal-0.4.5-makefile.patch b/x11-misc/apwal/files/apwal-0.4.5-makefile.patch
index 2c278b278a03..0925087c0c1f 100644
--- a/x11-misc/apwal/files/apwal-0.4.5-makefile.patch
+++ b/x11-misc/apwal/files/apwal-0.4.5-makefile.patch
@@ -27,8 +27,8 @@
else
-CFLAGS=-O2 `pkg-config --cflags gtk+-2.0 gthread-2.0`
-LDFLAGS=-O2 `pkg-config --libs gtk+-2.0 gthread-2.0` `xml2-config --libs`
-+CPPFLAGS=`pkg-config --cflags gtk+-2.0 gthread-2.0`
-+LIBS=`pkg-config --libs gtk+-2.0 gthread-2.0` `xml2-config --libs`
++CPPFLAGS=`${PKG_CONFIG} --cflags gtk+-2.0 gthread-2.0`
++LIBS=`${PKG_CONFIG} --libs gtk+-2.0 gthread-2.0` `xml2-config --libs`
endif
OBJS=main.o app.o launcher.o editor.o property.o \