summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-25 03:14:37 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-25 03:18:47 -0400
commit9eea83cbaee6338cc0665c8290376adb867a1295 (patch)
tree2cc31d473a23c632ea01310c9500974cbfb2beb5 /x11-misc
parentapp-emulation/lxd: drop 4.0.6-r1 (diff)
downloadgentoo-9eea83cbaee6338cc0665c8290376adb867a1295.tar.gz
gentoo-9eea83cbaee6338cc0665c8290376adb867a1295.tar.bz2
gentoo-9eea83cbaee6338cc0665c8290376adb867a1295.zip
x11-misc/unclutter-xfixes: add 1.6
No real changes but bump EAPI and respect PKG_CONFIG at same time Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/unclutter-xfixes/Manifest1
-rw-r--r--x11-misc/unclutter-xfixes/unclutter-xfixes-1.6.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/unclutter-xfixes/Manifest b/x11-misc/unclutter-xfixes/Manifest
index 6da6c4a74414..07e8feac982c 100644
--- a/x11-misc/unclutter-xfixes/Manifest
+++ b/x11-misc/unclutter-xfixes/Manifest
@@ -1 +1,2 @@
DIST unclutter-xfixes-1.5.tar.gz 7998 BLAKE2B 3eb6e259d85ca85eac3776fe1f4ff57dd3f2a8573f478880d174b3fb75ba23e54281e12b9d62243501539dee4225d3c64c5bf32a3c6aa1549f729ebd617ab5aa SHA512 0b8823d5ab64193f7e5fe03ceecbe0f475bbe36f78c4a0295705a80e9df1e5a8c4f65eb749b55e5b8b06aa3248e4f2fc1daac1b14b84aab157bdfbff39bba095
+DIST unclutter-xfixes-1.6.tar.gz 8965 BLAKE2B f0975c2fdf1409acf85cb44faf5d0e34a23bb934f8715fb19c9c67a2218f0f1ca85fd83b1a180be2d2362c2547ec040c4494247c63f5bb0bf74da9e779206aaf SHA512 aebcd85d0474471a3cd4a4e190692cf2fe91e47da1057b46e33ee79e5c47e3a488f4ac264530df71a0fbebeb679e0da33bafa19a29c73acd0ae62d0edf8acead
diff --git a/x11-misc/unclutter-xfixes/unclutter-xfixes-1.6.ebuild b/x11-misc/unclutter-xfixes/unclutter-xfixes-1.6.ebuild
new file mode 100644
index 000000000000..72b8c10b9675
--- /dev/null
+++ b/x11-misc/unclutter-xfixes/unclutter-xfixes-1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hides mouse pointer while not in use (rewrite of unclutter)"
+HOMEPAGE="https://github.com/Airblader/unclutter-xfixes"
+SRC_URI="https://github.com/Airblader/unclutter-xfixes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libev
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXi
+ !x11-misc/unclutter"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin unclutter
+ newman man/${PN}.1 unclutter.1
+ einstalldocs
+}