summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-11-18 22:05:19 +0100
committerSebastian Pipping <sping@gentoo.org>2021-11-18 22:05:19 +0100
commitb43a4298074b6d23db0eece7933a34ac5eae1538 (patch)
tree257d45db4f093ec967703d8696bd38f425d827ae /x11-misc
parentsys-boot/systemd-boot: add 249.6, drop 249 (diff)
downloadgentoo-b43a4298074b6d23db0eece7933a34ac5eae1538.tar.gz
gentoo-b43a4298074b6d23db0eece7933a34ac5eae1538.tar.bz2
gentoo-b43a4298074b6d23db0eece7933a34ac5eae1538.zip
x11-misc/grub2-theme-preview: py3.10 + DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/824406 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.28, Repoman-3.0.3
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/grub2-theme-preview/grub2-theme-preview-2.3.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/grub2-theme-preview/grub2-theme-preview-2.3.0-r1.ebuild b/x11-misc/grub2-theme-preview/grub2-theme-preview-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..b4a6ce2f5cbc
--- /dev/null
+++ b/x11-misc/grub2-theme-preview/grub2-theme-preview-2.3.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Preview a GRUB 2.x theme using KVM/QEMU"
+HOMEPAGE="https://github.com/hartwork/grub2-theme-preview"
+SRC_URI="https://github.com/hartwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="grub_platforms_efi-64"
+
+RDEPEND="app-emulation/qemu
+ dev-libs/libisoburn
+ sys-fs/mtools
+ grub_platforms_efi-64? (
+ sys-boot/grub:2[grub_platforms_efi-64]
+ sys-firmware/edk2-ovmf
+ )
+ !grub_platforms_efi-64? (
+ sys-boot/grub:2[grub_platforms_pc]
+ )
+"