summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-09-04 12:40:36 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-09-25 16:32:07 -0400
commitc6c1f223ac41abf68a2f486bdc483281561f0e8b (patch)
tree16dddceca572b881832d64e74aa18bb98480835f /x11-misc
parentmate-base/mate-panel: Bump to 1.24.1 (diff)
downloadgentoo-c6c1f223ac41abf68a2f486bdc483281561f0e8b.tar.gz
gentoo-c6c1f223ac41abf68a2f486bdc483281561f0e8b.tar.bz2
gentoo-c6c1f223ac41abf68a2f486bdc483281561f0e8b.zip
x11-misc/mate-notification-daemon: Bump to 1.24.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mate-notification-daemon/Manifest1
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
index 4f6e1c534bfa..bc5fae879848 100644
--- a/x11-misc/mate-notification-daemon/Manifest
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -1 +1,2 @@
DIST mate-notification-daemon-1.24.0.tar.xz 392588 BLAKE2B 480272848b3403d34eaa1f555a573dbf74a4e8e45e76c4726943bda4c29d7002f00d1a828e318d51dd07a44df1c64902c38bbe41c1c14339e8cb8710f7008f36 SHA512 0fd2da98001c60672d4833e974ac74dd561f54ca6f3fd74f8d6620e3b28768add46dd891d7446b01426b6aed09d4966d902cbde45aac3498fdcbb837e531a147
+DIST mate-notification-daemon-1.24.1.tar.xz 395444 BLAKE2B dca166664216c7027b2e816c7df64636c3f1c7ae25db253167f9c5d1b296cd9bf3c7533e1f7a33a7d4f2bf5fe074e8f0911462463fffa5b839fd8decd62a4716 SHA512 7c799e31229860cb34fa4a19421360a4a93d81826bc4381ed284e1ec280bae67d2f5bdf5d751f3dad6a1da424a5c598b2def60b7b24fd6ea41da5f126f456bac
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.1.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.1.ebuild
new file mode 100644
index 000000000000..b419b74c0364
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.9.0
+ >=sys-apps/dbus-1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ virtual/libintl
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon
+ !x11-misc/notification-daemon
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig
+"
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}