summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Chantziaras <realnc@gmail.com>2018-07-27 22:46:41 +0300
committerMichał Górny <mgorny@gentoo.org>2018-08-07 11:46:10 +0200
commitd0801af6658208e85edbaaefc4923735a9469fe2 (patch)
treebe9439d171879a28aa98b2ad09a80b8923a99419 /x11-misc
parentsys-libs/binutils-libs: Restore keywords of 2.31.1 (diff)
downloadgentoo-d0801af6658208e85edbaaefc4923735a9469fe2.tar.gz
gentoo-d0801af6658208e85edbaaefc4923735a9469fe2.tar.bz2
gentoo-d0801af6658208e85edbaaefc4923735a9469fe2.zip
x11-misc/kdocker: version bump to 5.2
Closes: https://bugs.gentoo.org/662308 Closes: https://github.com/gentoo/gentoo/pull/9363 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/kdocker/Manifest1
-rw-r--r--x11-misc/kdocker/kdocker-5.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/kdocker/Manifest b/x11-misc/kdocker/Manifest
index db68f1de65ca..ecb74c0a2dee 100644
--- a/x11-misc/kdocker/Manifest
+++ b/x11-misc/kdocker/Manifest
@@ -1,2 +1,3 @@
DIST KDocker-5.1.tar.gz 173340 BLAKE2B a15b833fba2a2d1e3f1b55ad4d115cb09f55a57981076332fc86b1e607bac470705b8bc909d15ddd912b43d301e8c217b1fd175947879f053b250d8684556424 SHA512 df5880e1c19a436ef6b8ee92426f989b77f4dfd11f3a6a2357f425419ea61cd69f51250a10e92962a893611f0a14504f698ccef09322d62d20f5d49a506c4a12
+DIST KDocker-5.2.tar.gz 173508 BLAKE2B e44a924a085c2d237c113028f40a98cfa8a8a5398525aea4e38fadabd23a10cc91648a55f800afd2ad398b744ad450d9c7bc26dd5bae994603f6ea4b322b5804 SHA512 1a98bf7b6360f4ce042b3e5330798076d42bd463c16e41b259706811f11516a34acfb0ace59f2c10c07aa6b2ff8fc57b1b1fa3ccdd33d452e220ec46446e8b64
DIST kdocker-5.0.tar.gz 152222 BLAKE2B b4e60a28f497476503f2a40aee4a776ece3a052adce4d29cb75095d9056ba0d6e4993838d6f771fad08532a3fb6d4022a07684f47cbd72289d34bce7196347aa SHA512 7c7702000621204d7e4acab295d43d05f71982af91524bc237878bdc9aa8851dc01a718bbe32412f46c718a1e358de8e710489a4beba9ef5b39359fe43662ba3
diff --git a/x11-misc/kdocker/kdocker-5.2.ebuild b/x11-misc/kdocker/kdocker-5.2.ebuild
new file mode 100644
index 000000000000..43c6d71eef65
--- /dev/null
+++ b/x11-misc/kdocker/kdocker-5.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 gnome2-utils qmake-utils
+
+MY_P=KDocker-${PV}
+DESCRIPTION="Helper to dock any application into the system tray"
+HOMEPAGE="https://github.com/user-none/KDocker"
+SRC_URI="https://github.com/user-none/KDocker/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXpm
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS BUGS ChangeLog CREDITS README.md TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ sed -i -e "/completion.path/s%/etc/bash_completion.d%$(get_bashcompdir)%" \
+ kdocker.pro || die "sed failed"
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" SYSTEMQTSA=1
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}