summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-05-12 16:20:29 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-05-12 17:03:32 -0400
commitdf6cdd5a04a07fb15c6e75a42acaaa1d4d67748d (patch)
tree3030fbb119ff10613d6c5de0bfd56f6133ead36d /x11-misc
parentmate-extra/mate-utils: Bump to 1.22.1, add missing deps (diff)
downloadgentoo-df6cdd5a04a07fb15c6e75a42acaaa1d4d67748d.tar.gz
gentoo-df6cdd5a04a07fb15c6e75a42acaaa1d4d67748d.tar.bz2
gentoo-df6cdd5a04a07fb15c6e75a42acaaa1d4d67748d.zip
x11-misc/mozo: Bump to 1.22.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mozo/Manifest1
-rw-r--r--x11-misc/mozo/mozo-1.22.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index 6af2e557fc5e..5812d0b96987 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -1 +1,2 @@
DIST mozo-1.22.0.tar.xz 178924 BLAKE2B 6cc74cbdb7342d926483948391798cc9b0be66b63bba758b7ec8cea3f5555ae01f1ecf279053612ed060a283076bdac1a9ef8bd15e3cfe61d96685aeee168ae0 SHA512 f3d60e94d9bf5fdd435320856563622f0687cc2844a3d51473bcef5c442f4938a4030533271ead2fd88fb0ce805c16b40d629e5a69fc642e7e670a1afd5745db
+DIST mozo-1.22.1.tar.xz 171976 BLAKE2B c4a1166b605d3fed68b71987dbf70b7f908aabc2c7266415b0d7ce4c8ccb93ad690c72ce83a708f9d3518cfba66128d2cd4bc5413432133299595cf4d2c5a43c SHA512 6cd4ed04d43ae064077fc78ed59644bf6efe4c65c26995742166c57333d470fbe95ca4f4037e786f16dc076e75d938868948e8c2e5c662f35d971b36992f1a9b
diff --git a/x11-misc/mozo/mozo-1.22.1.ebuild b/x11-misc/mozo/mozo-1.22.1.ebuild
new file mode 100644
index 000000000000..9c950c49491a
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.22.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ virtual/libintl
+ !!x11-misc/mate-menu-editor"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}