summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-06-17 18:06:02 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-17 20:44:23 +0200
commite01c3996f4ab65de36d6ea62836abc9df76889ce (patch)
tree337847e456ec298974656253f48e41c8de36210d /x11-misc
parentprofiles: powerpc: Follow-up cleanup of PyQt5-revdeps masks (diff)
downloadgentoo-e01c3996f4ab65de36d6ea62836abc9df76889ce.tar.gz
gentoo-e01c3996f4ab65de36d6ea62836abc9df76889ce.tar.bz2
gentoo-e01c3996f4ab65de36d6ea62836abc9df76889ce.zip
x11-misc/libinput-gestures: version bump to 2.36
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8876
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/libinput-gestures/Manifest1
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-2.36.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-misc/libinput-gestures/Manifest b/x11-misc/libinput-gestures/Manifest
index e94859e40882..bf5a7854a548 100644
--- a/x11-misc/libinput-gestures/Manifest
+++ b/x11-misc/libinput-gestures/Manifest
@@ -1,2 +1,3 @@
DIST libinput-gestures-2.31.tar.gz 15872 BLAKE2B 0fe671f50ee6e7b06362591d68d259587347794c80df27c73d833e459eb9499ae919bf3e4f12e1dfc2852fd9b70c3962963f3a291107bab8ea0a8f1576dddde4 SHA512 fc3c90025486c8da5b2419f99666737dca40dfc962a549bd1955ea792137a1377a9697c8cab908991503fa9dd6d72520a04ac2dbc9463bc228566569be43ca67
DIST libinput-gestures-2.34.tar.gz 16321 BLAKE2B ae1fc850a075fd0b8e4aec6b94f0257f10f309a28a4893aad608eff59afede28b4126734a14f510ca569f64d79492461000dfca8c34e614a5e99839f3c5d952d SHA512 47ffa36b9abb01e62a046d1135cf3ec2773285f94ba68d66c03f877b6acf057491fb4a7645198d8c3bde39e38e12e039f3b10c6987d5765798d969d23359269f
+DIST libinput-gestures-2.36.tar.gz 16598 BLAKE2B 3c30408ce394cf8bbc5a68c5f37c9106bb481ad47c75f25bfbba7470da0cbfb330512fe0422588408f177085c23a5cf0379c13a49c9fce438e8d8b1179c91d50 SHA512 69f77d0681f37deee3f215e71e4410d5c45107d2d0a1addb897de14d7f83bcb3e2285ed9ba605f30db23441a9d7bc9a6960b2a49d53ad71a379d0b874d36d645
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.36.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.36.ebuild
new file mode 100644
index 000000000000..39fb049c736d
--- /dev/null
+++ b/x11-misc/libinput-gestures/libinput-gestures-2.36.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/libinput-gestures"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bulletmark/${PN}.git"
+else
+ SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/libinput-1.8.0
+ x11-misc/xdotool
+ x11-misc/wmctrl"
+DEPEND=">=dev-libs/libinput-1.8.0
+ dev-util/desktop-file-utils
+ test? ( dev-python/flake8[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ default
+
+ # Fix docdir installation path
+ sed '/^DOCDIR/s@$NAME@${PF}@' -i libinput-gestures-setup || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "You must be in the input group to read the touchpad device."
+
+ if ! has_version x11-libs/gtk+:3 ; then
+ elog "${PN}-setup script supports Gnome 3 via x11-libs/gtk+:3."
+ fi
+ if ! has_version kde-plasma/kde-cli-tools:5 ; then
+ elog "${PN}-setup script supports Plasma 5 via kde-plasma/kde-cli-tools:5."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}