summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2021-11-22 14:00:55 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2021-11-22 14:01:06 +0000
commitf062f0d8502c37741d04fb2b6167c787b73a9412 (patch)
tree1215bf811ce0ba0db0b585c5203725c7f48a9a80 /x11-misc
parentsys-libs/musl: fix ldconfig on SELinux (diff)
downloadgentoo-f062f0d8502c37741d04fb2b6167c787b73a9412.tar.gz
gentoo-f062f0d8502c37741d04fb2b6167c787b73a9412.tar.bz2
gentoo-f062f0d8502c37741d04fb2b6167c787b73a9412.zip
x11-misc/i3status: version bump using meson
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/i3status/Manifest1
-rw-r--r--x11-misc/i3status/i3status-2.14.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/i3status/Manifest b/x11-misc/i3status/Manifest
index ab1c2b4c1da3..56f072db9c04 100644
--- a/x11-misc/i3status/Manifest
+++ b/x11-misc/i3status/Manifest
@@ -1 +1,2 @@
DIST i3status-2.13.tar.bz2 201409 BLAKE2B e087d69e2df3ae9348cb55739023b2164dfa3543551d173b138c72e574714069d8397716b95e92c4315aa538ea31b33aa73532d6d0f75bbc38d7db54e1f665bc SHA512 6dadff19e53499d169ba4f491e1f821014b4f92fc3c93d7947c85cbbbdeaba538d02bd8ab98fe266a8f80756a287fd5803ec77a8cd874d50082b5cad309875c2
+DIST i3status-2.14.tar.xz 68900 BLAKE2B e85019c2a95d50b6bd4adc6bc9dafb85c3a3d8cdaa93602a9c2af54e6818a4e58ad26f47e2c85b38744c12c08f52c4b5c1216e6f3215f8ee2f4152b42a547905 SHA512 10a1235cc314f5fc4dde4e1369a30f49118c95271f636c5803caa52d94d99ad8565b89fcd602d0c8aa7c830a79d3a3bb08e5ac8123cf07cfddc8ef0126b10f80
diff --git a/x11-misc/i3status/i3status-2.14.ebuild b/x11-misc/i3status/i3status-2.14.ebuild
new file mode 100644
index 000000000000..a79b79410fec
--- /dev/null
+++ b/x11-misc/i3status/i3status-2.14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit fcaps autotools meson
+
+DESCRIPTION="generates a status bar for dzen2, xmobar or similar"
+HOMEPAGE="https://i3wm.org/i3status/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="pulseaudio"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ >=dev-libs/yajl-2.0.2
+ dev-libs/confuse:=
+ dev-libs/libnl:3
+ media-libs/alsa-lib
+ pulseaudio? ( || ( media-sound/pulseaudio media-sound/apulse[sdk] ) )
+"
+
+DEPEND="
+ ${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+"
+
+PATCHES=(
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use pulseaudio pulseaudio)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ fcaps cap_net_admin usr/bin/${PN}
+
+ elog "${PN} can be used with any of the following programs:"
+ elog " i3bar (x11-wm/i3)"
+ elog " x11-misc/xmobar"
+ elog " x11-misc/dzen"
+ elog "Please refer to manual: man ${PN}"
+}