summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-08 06:12:04 +0100
committerSam James <sam@gentoo.org>2021-09-08 06:12:04 +0100
commitf4609296a949159c046762c4a98624bf9ac2e12c (patch)
tree8d5b9df15d15ec12e0a29257bd9407a5ace07099 /x11-misc
parentdev-libs/unibilium: add 2.1.1 (diff)
downloadgentoo-f4609296a949159c046762c4a98624bf9ac2e12c.tar.gz
gentoo-f4609296a949159c046762c4a98624bf9ac2e12c.tar.bz2
gentoo-f4609296a949159c046762c4a98624bf9ac2e12c.zip
x11-misc/xnee: fix build with slibtool
Closes: https://bugs.gentoo.org/778962 Thanks-to: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xnee/files/xnee-3.19-slibtool.patch19
-rw-r--r--x11-misc/xnee/xnee-3.19-r2.ebuild3
2 files changed, 22 insertions, 0 deletions
diff --git a/x11-misc/xnee/files/xnee-3.19-slibtool.patch b/x11-misc/xnee/files/xnee-3.19-slibtool.patch
new file mode 100644
index 000000000000..411cfd617490
--- /dev/null
+++ b/x11-misc/xnee/files/xnee-3.19-slibtool.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/778962
+https://savannah.gnu.org/support/index.php?110470
+
+Author: orbea <orbea@riseup.net>
+Date: Thu Apr 1 14:39:10 2021 -0700
+
+ build: Fix build with slibtool.
+
+--- a/cnee/src/Makefile.am
++++ b/cnee/src/Makefile.am
+@@ -63,7 +63,7 @@ endif
+
+
+ AM_CFLAGS = -I../include -I${LIBXNEE_DIR}/include ${PEDANTIC_FLAGS} ${X_CFLAGS} -g ${VERBOSE_FLAG} ${BUF_VERBOSE_FLAG} ${USER_CFLAGS} ${GCOV_FLAG} ${GPROF_FLAG} ${XNEE_XINPUT_SUPPORT_FLAGS} ${XNEE_XINPUT_SUPPORT_FLAGS}
+-cnee_LDADD = -L${LIBXNEE_DIR}/src -lxnee ${X_LIBS} ${X11_LIBS} ${LIBDL} ${LIBXI}
++cnee_LDADD = $(top_srcdir)/libxnee/src/libxnee.la ${X_LIBS} ${X11_LIBS} ${LIBDL} ${LIBXI}
+
+ if BUILD_STATIC
+ STATIC_FLAGS = -static
diff --git a/x11-misc/xnee/xnee-3.19-r2.ebuild b/x11-misc/xnee/xnee-3.19-r2.ebuild
index 17cd30ca867e..f87a29dadb4b 100644
--- a/x11-misc/xnee/xnee-3.19-r2.ebuild
+++ b/x11-misc/xnee/xnee-3.19-r2.ebuild
@@ -45,10 +45,13 @@ DOCS=( AUTHORS BUGS ChangeLog FAQ NEWS README TODO )
PATCHES=(
"${FILESDIR}"/${PN}-3.18-linker.patch
"${FILESDIR}"/${P}-libgnomeui-only-for-applets.patch
+ "${FILESDIR}"/${P}-slibtool.patch
)
src_prepare() {
default
+
+ mv configure.{in,ac} || die
eautoreconf
}