summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-09-02 08:29:14 +0200
committerJeroen Roovers <jer@gentoo.org>2019-09-02 08:30:48 +0200
commitfcaee51a1356bea2e2652ed26c8cccf323b48488 (patch)
treeb50d219f8bce243c1de9f611036a9c103224b6d1 /x11-misc
parentx11-drivers/nvidia-drivers: Version 435.21 (diff)
downloadgentoo-fcaee51a1356bea2e2652ed26c8cccf323b48488.tar.gz
gentoo-fcaee51a1356bea2e2652ed26c8cccf323b48488.tar.bz2
gentoo-fcaee51a1356bea2e2652ed26c8cccf323b48488.zip
x11-misc/zim: Version 0.72.0
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/zim/Manifest1
-rw-r--r--x11-misc/zim/zim-0.72.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index d31a1828cdd7..30c31f484272 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -2,3 +2,4 @@ DIST zim-0.65.tar.gz 1899614 BLAKE2B e7989d91120f2ffe0668c996b5abd61cc1cb12b2a5a
DIST zim-0.69.tar.gz 2044631 BLAKE2B 447fa4fb2d11b1399668ec6b627e23150577b574afb1e5c33738cb690779f49adb2d60e0b01eb82d2cf0dfd4a430099c1ae4b52186b60a2564c501b93aa01822 SHA512 452b2119d63927765c3807dbbdfadea94be31ee7fd3eb9b8cf79e8699c57478ec9cd392299a6e1dc3690dbe520925cddf5fca4596db809a2cc296bb6669d12af
DIST zim-0.71.0.tar.gz 2882942 BLAKE2B f1701baf547d43d7a9687e6a1d72313649064f1d3927e14bffd5c8e348fa7a311e307f9b1704c19058bfad07d6715c79399acfdc5701efa9291db3e68065175a SHA512 7c82e19d547795f57c563383aca04a51da02463df71cfe18c4cab0307f46fb425ff0f348b43ae0ab26cb29037bc9d99aed63dbf721a542d071f9674f17f0a64a
DIST zim-0.71.1.tar.gz 2883082 BLAKE2B 66d1c571a67e12d8d38cbc6d8bd32918f98f47bff0aa34971986896b3aeec91170cd1f2a87a411a8fccda502addd3de8176cc70ebfbafedc87c462a751e87036 SHA512 0da59955f730cc0bbee033a292c7e531b1a302c950773aed68bd8a18bf1485826086522c4144f24f500e9240ebcb9b592b33dda390923ca0eba6ab57273c0896
+DIST zim-0.72.0.tar.gz 2590406 BLAKE2B 0d77052e9eaa62b855be30eee64863197498ee54949f8610528ccd86cf32e7c9c55fb2faca719a4d92e0568941dc6b100299e76a33f8c49bddc5e367ec98d923 SHA512 60f59c2cf2ebb920515ecbc77e7fb1ddb9b0a6f6179503176b582b6b87ada759707ec4ccee929896a8a7d489f25ff13f7a6ff61fa637ecdb3d02640182cda0b9
diff --git a/x11-misc/zim/zim-0.72.0.ebuild b/x11-misc/zim/zim-0.72.0.ebuild
new file mode 100644
index 000000000000..1dbe5acb22de
--- /dev/null
+++ b/x11-misc/zim/zim-0.72.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+inherit xdg-utils distutils-r1 virtualx
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="
+ https://zim-wiki.org/
+ https://github.com/zim-desktop-wiki/zim-desktop-wiki
+"
+SRC_URI="https://github.com/${PN}-desktop-wiki/${PN}-desktop-wiki/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xdg-utils
+"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS=( CHANGELOG.md CONTRIBUTING.md PLUGIN_WRITING.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+S=${WORKDIR}/${PN}-desktop-wiki-${PV/_/-}
+
+python_prepare_all() {
+ sed -i -e "s/'USER'/'LOGNAME'/g" zim/__init__.py zim/fs.py || die
+
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ if ! has_version ${CATEGORY}/${PN}; then
+ elog "Please install these packages for additional functionality"
+ elog " dev-lang/R"
+ elog " dev-python/gtkspell-python"
+ elog " dev-vcs/bzr"
+ elog " media-gfx/graphviz"
+ elog " media-gfx/imagemagick"
+ elog " media-gfx/scrot"
+ elog " media-sound/lilypond"
+ elog " sci-visualization/gnuplot"
+ elog " virtual/latex-base app-text/dvipng"
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}