summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/compiz-plugins-extra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/compiz-plugins-extra')
-rw-r--r--x11-plugins/compiz-plugins-extra/Manifest1
-rw-r--r--x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild65
-rw-r--r--x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.8-libnotify.patch19
-rw-r--r--x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-no-gconf.patch21
-rw-r--r--x11-plugins/compiz-plugins-extra/metadata.xml17
5 files changed, 123 insertions, 0 deletions
diff --git a/x11-plugins/compiz-plugins-extra/Manifest b/x11-plugins/compiz-plugins-extra/Manifest
new file mode 100644
index 000000000000..e1ee41b6f11d
--- /dev/null
+++ b/x11-plugins/compiz-plugins-extra/Manifest
@@ -0,0 +1 @@
+DIST compiz-plugins-extra-0.8.8.tar.bz2 2689953 SHA256 bdce203098c62370b01b87741b04d3d9bc37e918789acce07120c4f081d5bbe3 SHA512 de72d688648e5426e8967cc88d9439d19c0bc57dcd4de7c5a78fbf2e1dcec85f5f69c89e6affa06f8df1534dad4b347041d023ea9eeabb034df485825815ca22 WHIRLPOOL 13934f28685384bf2ee64e987352b24c848981a69e54503e2931b1446380e74bb8396e3b792c0cac9cc869277cb0ecbf4af4b9a5da8cf6017b26f12d73171f2a
diff --git a/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild
new file mode 100644
index 000000000000..e869ea420830
--- /dev/null
+++ b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Compiz Fusion Window Decorator Extra Plugins"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gconf libnotify"
+
+RDEPEND="
+ >=gnome-base/librsvg-2.14.0:2
+ virtual/jpeg:0
+ >=x11-libs/compiz-bcop-${PV}
+ >=x11-plugins/compiz-plugins-main-${PV}
+ >=x11-wm/compiz-${PV}[gconf?]
+ libnotify? ( x11-libs/libnotify )
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.15
+ x11-libs/cairo
+ gconf? ( gnome-base/gconf:2 )
+"
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
+
+src_prepare() {
+ if ! use gconf; then
+ epatch "${FILESDIR}"/${PN}-no-gconf.patch
+ fi
+ epatch "${FILESDIR}/${P}-libnotify.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-fast-install \
+ --disable-static \
+ $(use_enable gconf schemas) \
+ $(use_with libnotify notifications)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
+
+pkg_preinst() {
+ use gconf && gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ use gconf && gnome2_gconf_install
+}
diff --git a/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.8-libnotify.patch b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.8-libnotify.patch
new file mode 100644
index 000000000000..9287d706ac8e
--- /dev/null
+++ b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.8-libnotify.patch
@@ -0,0 +1,19 @@
+--- configure.ac 2011-04-21 15:51:08.000000000 +0400
++++ configure.ac 2012-08-16 21:37:46.894173595 +0400
+@@ -136,7 +136,15 @@
+ PKG_CHECK_MODULES(COMPIZMOUSEPOLL, compiz-mousepoll, [have_compiz_mousepoll=yes], [have_compiz_mousepoll=no])
+ AM_CONDITIONAL(SHOWMOUSE_PLUGIN, test "x$have_compiz_mousepoll" = "xyes")
+
+-PKG_CHECK_MODULES(LIBNOTIFY, libnotify gtk+-2.0, [have_libnotify=yes], [have_libnotify=no])
++AC_ARG_ENABLE(notifications, AS_HELP_STRING([--enable-notifications], [Build notification plugin]), [enable_notifications=$enableval], [enable_notification=auto])
++if test "$enable_notification" = auto; then
++ PKG_CHECK_MODULES(LIBNOTIFY, libnotify gtk+-2.0, [have_libnotify=yes], [have_libnotify=no])
++fi
++if test "$enable_notification" = yes; then
++ PKG_CHECK_MODULES(LIBNOTIFY, libnotify gtk+-2.0, [have_libnotify=yes], AC_MSG_ERROR([Libnotify is not installed]))
++else
++ have_libnotify=no
++fi
+ AM_CONDITIONAL(NOTIFICATION_PLUGIN, test "x$have_libnotify" = "xyes")
+ if test "$have_libnotify" = yes; then
+ AC_DEFINE(USE_NOTIFICATION, 1, [Build notification plugin])
diff --git a/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-no-gconf.patch b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-no-gconf.patch
new file mode 100644
index 000000000000..49bf16be4b10
--- /dev/null
+++ b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-no-gconf.patch
@@ -0,0 +1,21 @@
+ configure.ac | 5 ++---
+ 1 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0a3d7c1..6f8356d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -150,11 +150,10 @@ if test x"$use_schemas" = x"yes"; then
+ fi
+ xsltdir=`$PKG_CONFIG --variable=xsltdir compiz-gconf`
+ AC_SUBST(xsltdir)
++else
++ AM_CONDITIONAL(GCONF_SCHEMAS_INSTALL, test "x$use_gconf" = "xyes")
+ fi
+
+-AM_GCONF_SOURCE_2
+-
+-
+ AM_CONDITIONAL(USE_SCHEMAS, test "x$use_schemas" = "xyes")
+ if test "$use_schemas" = yes; then
+ AC_DEFINE(USE_SCHEMAS, 1, [Build gconf schemas])
diff --git a/x11-plugins/compiz-plugins-extra/metadata.xml b/x11-plugins/compiz-plugins-extra/metadata.xml
new file mode 100644
index 000000000000..907c49177fbd
--- /dev/null
+++ b/x11-plugins/compiz-plugins-extra/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-effects</herd>
+<longdescription lang="en">
+>Package with several compiz-fusion plugins:
+addhelper, bench, crashhandler, cubecaps, cubereflex, extrawm, fadedesktop, firepaint, gears,
+goto-viewport, group, mblur, reflex, scalefilter, showdesktop, splash, trailfocus, widget.
+</longdescription>
+ <use>
+ <flag name="gconf">
+ Install GConf schemas for the plugins, needed when using the GConf-based
+ configuration backend in <pkg>x11-wm/compiz</pkg>.
+ </flag>
+ </use>
+</pkgmetadata>
+