summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/epplets
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/epplets')
-rw-r--r--x11-plugins/epplets/Manifest2
-rw-r--r--x11-plugins/epplets/epplets-0.12.ebuild27
-rw-r--r--x11-plugins/epplets/epplets-0.14.ebuild33
-rw-r--r--x11-plugins/epplets/metadata.xml17
4 files changed, 79 insertions, 0 deletions
diff --git a/x11-plugins/epplets/Manifest b/x11-plugins/epplets/Manifest
new file mode 100644
index 000000000000..8940a1b76dad
--- /dev/null
+++ b/x11-plugins/epplets/Manifest
@@ -0,0 +1,2 @@
+DIST epplets-0.12.tar.gz 894232 SHA256 676522217e91955cda67ba1f7dcd11f9242685af5652ea408cd6128a8b332ce2 SHA512 b8b017ed4199f6a083db4e66090611e24d50428d287b1ef414725e68bc48ecedc3f6a3c9f68d38645e9146739e35e43ca08197d832b38d580039f3a050de93dc WHIRLPOOL b7fc0602c54ec63961d409ffdc1bd1ae8b5f603ac9cdf20a7cb06f9133769e2c90d7cec872ff22baf0b744a616102d08f58c2a240019c83e38c253a55de43950
+DIST epplets-0.14.tar.gz 971885 SHA256 e3d1520344532f602a0a7807cda363d6435655aed302967a8580f102e3468132 SHA512 d83d60521fe06497f109c3fbb5c2e10abd36a43b050c10787a68d9f9f8c2866f57d78a8559a482654d9bb0eaaf3ce791e4839bb0fda88ccbf026d8ec5dc93824 WHIRLPOOL 1e53c3c337a61104a46fa5bcbc1d38b7936e0e4b40c46bd4fdb8a7f88302e5c8adc16ca22b1cba3a18b179a4dd15f6e015c6cdcc2f812bcbaace4ea408c51596
diff --git a/x11-plugins/epplets/epplets-0.12.ebuild b/x11-plugins/epplets/epplets-0.12.ebuild
new file mode 100644
index 000000000000..738cba81b13c
--- /dev/null
+++ b/x11-plugins/epplets/epplets-0.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Base files for Enlightenment epplets and some epplets"
+HOMEPAGE="http://www.enlightenment.org/"
+SRC_URI="mirror://sourceforge/enlightenment/epplets-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ media-libs/freeglut
+ media-libs/imlib2
+ >=x11-wm/enlightenment-0.16.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
diff --git a/x11-plugins/epplets/epplets-0.14.ebuild b/x11-plugins/epplets/epplets-0.14.ebuild
new file mode 100644
index 000000000000..5f4d2c769fc7
--- /dev/null
+++ b/x11-plugins/epplets/epplets-0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Base files for Enlightenment epplets and some epplets"
+HOMEPAGE="http://www.enlightenment.org/"
+SRC_URI="mirror://sourceforge/enlightenment/epplets-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ media-libs/freeglut
+ media-libs/imlib2
+ >=x11-wm/enlightenment-0.16.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}
diff --git a/x11-plugins/epplets/metadata.xml b/x11-plugins/epplets/metadata.xml
new file mode 100644
index 000000000000..3e6098cb0144
--- /dev/null
+++ b/x11-plugins/epplets/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Epplets are small, handy Enlightenment applets, similar to "dockapps"
+or "applets" for other packages. The epplets package contains the
+base epplet API library and header files, as well as the core set of
+epplets, including CPU monitors, clocks, a mail checker, mixers, a
+slideshow, a URL grabber, a panel-like toolbar, and more.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">enlightenment</remote-id>
+ </upstream>
+</pkgmetadata>