summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-07 00:06:55 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-07 00:07:13 -0400
commit51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46 (patch)
tree87ee66d099783dbc1cfc6d2fcc70f2a170775904 /x11-plugins/gkrellm-imonc/files
parentapp-vim/csound-syntax: version bump to 20160804 (diff)
downloadgentoo-51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46.tar.gz
gentoo-51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46.tar.bz2
gentoo-51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46.zip
x11-plugins/gkrellm-imonc: new revision that respects LDFLAGS.
This is another revision thanks to Michael Mair-Keimberger. His patch fixes the Makefile so that it adds $(LDFLAGS) in the right spots, and also happens to fix $(CC) in the process. An EAPI=2 USE-dependency was added for gkrellm (also part of the patch), and the ebuild was updated to use EAPI=6. Gentoo-Bug: 335013 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/gkrellm-imonc/files')
-rw-r--r--x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch b/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch
new file mode 100644
index 000000000000..598e5d8460c7
--- /dev/null
+++ b/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch
@@ -0,0 +1,35 @@
+--- a/Makefile 2003-05-17 20:08:29.000000000 +0200
++++ b/Makefile 2013-03-13 18:24:24.552941672 +0100
+@@ -9,12 +9,10 @@
+ GTK_INCLUDE = $(shell pkg-config gtk+-2.0 --cflags)
+ GTK_LIB = $(shell pkg-config gtk+-2.0 --libs)
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
++FLAGS = -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
+
+-LFLAGS = -shared
+-
+-CC = gcc
++LFLAGS = -shared
+
+ #
+ # files
+@@ -30,7 +28,7 @@
+
+
+ %.o : %.c
+- $(CC) $(CFLAGS) $(FLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) -c $< -o $@
+
+
+ all:
+@@ -41,7 +39,7 @@
+
+ $(TARGET): $(OBJECTS)
+ @echo -e "\n\n>> linking\n"
+- $(CC) $(OBJECTS) -o $@ $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJECTS) -o $@ $(LFLAGS) $(LIBS)
+ @echo -e "\n<< done "
+
+ install: gkrellm-imonc.so