summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 23:34:33 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-04 10:16:01 +0100
commitac70897f8ce3a674e3802d7b4f0d8ab51b8357ea (patch)
tree2b1b2a8b60c7c0b76b25700305451bc1189d3bba /x11-plugins/gkrellm-radio
parentx11-plugins/gkrellm-bluez: Eclass update (diff)
downloadgentoo-ac70897f8ce3a674e3802d7b4f0d8ab51b8357ea.tar.gz
gentoo-ac70897f8ce3a674e3802d7b4f0d8ab51b8357ea.tar.bz2
gentoo-ac70897f8ce3a674e3802d7b4f0d8ab51b8357ea.zip
x11-plugins/gkrellm-radio: Eclass update
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-plugins/gkrellm-radio')
-rw-r--r--x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
index 541296313c57..5f7915f98273 100644
--- a/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
+++ b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
@@ -1,28 +1,29 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="A minimalistic GKrellM2 plugin to control radio tuners"
SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
HOMEPAGE="http://gkrellm.luon.net/gkrellm-radio.php"
-DEPEND="lirc? ( app-misc/lirc )"
-RDEPEND="${DEPEND}
- app-admin/gkrellm[X]
-"
-
-IUSE="lirc"
-SLOT="2"
LICENSE="GPL-2"
+SLOT="2"
KEYWORDS="~amd64 ppc sparc x86"
+IUSE="lirc"
-PLUGIN_SO="radio.so"
-S="${WORKDIR}/${PN}"
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ lirc? ( app-misc/lirc )"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${PN}
PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+PLUGIN_SO=( radio$(get_modname) )
+
src_compile() {
use lirc && myconf="${myconf} WITH_LIRC=1"
emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ${myconf}