summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/gkrellmss
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/gkrellmss')
-rw-r--r--x11-plugins/gkrellmss/Manifest1
-rw-r--r--x11-plugins/gkrellmss/files/gkrellmss-2.6-Respect-LDFLAGS.patch25
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild30
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild34
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6.ebuild30
-rw-r--r--x11-plugins/gkrellmss/metadata.xml5
6 files changed, 125 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmss/Manifest b/x11-plugins/gkrellmss/Manifest
new file mode 100644
index 000000000000..bcd22ff26479
--- /dev/null
+++ b/x11-plugins/gkrellmss/Manifest
@@ -0,0 +1 @@
+DIST gkrellmss-2.6.tar.gz 32082 SHA256 370da16c1247dec9d64cb56c568e218b0b5a1e294ad55fa8776408c75a916f4b
diff --git a/x11-plugins/gkrellmss/files/gkrellmss-2.6-Respect-LDFLAGS.patch b/x11-plugins/gkrellmss/files/gkrellmss-2.6-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..59f1d0a200f9
--- /dev/null
+++ b/x11-plugins/gkrellmss/files/gkrellmss-2.6-Respect-LDFLAGS.patch
@@ -0,0 +1,25 @@
+From 88d25e2e4fe3edbb832d0bb2b44cd705b060360a Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <lack@gentoo.org>
+Date: Wed, 11 Aug 2010 08:37:20 -0400
+Subject: [PATCH] Respect LDFLAGS
+
+---
+ src/Makefile | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index e618bd4..35a1453 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -78,6 +78,8 @@ LFLAGS = -shared
+ STRIP ?= -s
+ endif
+
++LFLAGS += $(LDFLAGS)
++
+ ifeq ($(debug),1)
+ FLAGS += -g
+ endif
+--
+1.7.2
+
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
new file mode 100644
index 000000000000..3764b06b8f40
--- /dev/null
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gkrellm-plugin
+
+DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
+HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
+SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ~sparc x86"
+IUSE="nls"
+
+RDEPEND="=sci-libs/fftw-3*
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+PLUGIN_SO="src/gkrellmss.so"
+PLUGIN_DOCS="Themes"
+
+src_compile() {
+ local myconf
+ use nls && myconf+=" enable_nls=1"
+
+ addpredict /dev/snd
+ emake ${myconf}
+}
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild
new file mode 100644
index 000000000000..ae73d01d55ef
--- /dev/null
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gkrellm-plugin
+
+DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
+HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
+SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="=sci-libs/fftw-3*
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+PLUGIN_SO="src/gkrellmss.so"
+PLUGIN_DOCS="Themes"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Respect-LDFLAGS.patch
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf+=" enable_nls=1"
+
+ addpredict /dev/snd
+ emake ${myconf}
+}
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
new file mode 100644
index 000000000000..261de1596468
--- /dev/null
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gkrellm-plugin
+
+DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
+HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
+SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc sparc x86"
+IUSE="nls"
+
+RDEPEND="=sci-libs/fftw-2*
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+PLUGIN_SO="src/gkrellmss.so"
+PLUGIN_DOCS="Themes"
+
+src_compile() {
+ local myconf
+ use nls && myconf+=" enable_nls=1"
+
+ addpredict /dev/snd
+ emake ${myconf}
+}
diff --git a/x11-plugins/gkrellmss/metadata.xml b/x11-plugins/gkrellmss/metadata.xml
new file mode 100644
index 000000000000..a03f5d8b381b
--- /dev/null
+++ b/x11-plugins/gkrellmss/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+</pkgmetadata>