summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-07-26 12:55:42 +0200
committerPacho Ramos <pacho@gentoo.org>2017-07-26 13:34:25 +0200
commitc8c9e40e6de74a81edb5828dd9dd445d1d901765 (patch)
treebd5c38cb8027ad1f990def05664689ff3aea5a66 /x11-plugins/gkrellmss
parentx11-plugins/gkrellmoon: Fix dependency on gkrellm[X] (diff)
downloadgentoo-c8c9e40e6de74a81edb5828dd9dd445d1d901765.tar.gz
gentoo-c8c9e40e6de74a81edb5828dd9dd445d1d901765.tar.bz2
gentoo-c8c9e40e6de74a81edb5828dd9dd445d1d901765.zip
x11-plugins/gkrellmss: Fix dependency on gkrellm[X]
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-plugins/gkrellmss')
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r4.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r4.ebuild
new file mode 100644
index 000000000000..d18a72ab12e8
--- /dev/null
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gkrellm-plugin
+
+DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
+HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
+SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ app-admin/gkrellm[X]
+ media-libs/alsa-lib
+ sci-libs/fftw:3.0=
+"
+DEPEND="${RDEPEND}"
+
+PLUGIN_SO="src/gkrellmss.so"
+PLUGIN_DOCS="Themes"
+
+PATCHES=( "${FILESDIR}/${P}-Respect-LDFLAGS.patch" )
+
+src_compile() {
+ addpredict /dev/snd
+ emake enable_nls=$(usex nls 1 0)
+}