summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/gkrellstock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/gkrellstock')
-rw-r--r--x11-plugins/gkrellstock/Manifest2
-rw-r--r--x11-plugins/gkrellstock/files/gkrellstock-0.5-ldflags.patch16
-rw-r--r--x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild42
-rw-r--r--x11-plugins/gkrellstock/gkrellstock-0.5.1.ebuild42
-rw-r--r--x11-plugins/gkrellstock/metadata.xml8
5 files changed, 110 insertions, 0 deletions
diff --git a/x11-plugins/gkrellstock/Manifest b/x11-plugins/gkrellstock/Manifest
new file mode 100644
index 000000000000..173697e8ba73
--- /dev/null
+++ b/x11-plugins/gkrellstock/Manifest
@@ -0,0 +1,2 @@
+DIST gkrellstock-0.5.1.tar.gz 22385 SHA256 56711b5b19cb747dfc5fbb99c00a542a9df55959f88c9664edc2df3829115f61 SHA512 040e6271a0b0ca3f7be52cc64076a8d1b538fc7607a9ae54acf1c9dc176b094c1483b10c1813a929dcf47dff4fee8c18b7ca58472343c83edfa58a32edc7776c WHIRLPOOL 7ec087847de4c600110857fa4aea8f91a92f51e2ad0c88e8bd22741235a9247c68c72e454d385dcca104c56429f8c8e455bcb398f54ad57cc6a0270f7dfd7bf9
+DIST gkrellstock-0.5.tar.gz 22332 SHA256 1eb3ff7bf6fa8161f8b6cd8f99e3e5871fabd29866aad89ed3e2b7c2198f9e2a SHA512 8081bb1be1c640cd9853083fd22f931ffe6dbca359d86242df50e9684d2e856fd147692a716f7df4f4d496bc17e38988a40e7f547832dfaf61c2ed17d0b90b3d WHIRLPOOL 57b02ba1658fd5b587f703210cfda4364056d2336e695c107a45a258885bce8d8fe81f52b0603d1d25f0deea42a2431b4dbad6f3f5526e3474b858e145405a69
diff --git a/x11-plugins/gkrellstock/files/gkrellstock-0.5-ldflags.patch b/x11-plugins/gkrellstock/files/gkrellstock-0.5-ldflags.patch
new file mode 100644
index 000000000000..116e6ec3e4bd
--- /dev/null
+++ b/x11-plugins/gkrellstock/files/gkrellstock-0.5-ldflags.patch
@@ -0,0 +1,16 @@
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index eb26b17..79e4391 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,7 +10,7 @@ CC = gcc $(CFLAGS) $(FLAGS)
+ OBJS = gkrellstock.o
+
+ gkrellstock.so: $(OBJS)
+- $(CC) $(OBJS) -o gkrellstock.so $(LFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) $(OBJS) -o gkrellstock.so $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
diff --git a/x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild b/x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild
new file mode 100644
index 000000000000..a4928daf908f
--- /dev/null
+++ b/x11-plugins/gkrellstock/gkrellstock-0.5-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="Get Stock quotes plugin for Gkrellm2"
+HOMEPAGE="http://gkrellstock.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/GkrellM2.0%20Port/${PV}/${P}.tar.gz"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ dev-perl/libwww-perl
+ dev-perl/Finance-Quote"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/s/S}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
+ append-flags -fPIC
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install () {
+ gkrellm-plugin_src_install
+
+ dobin GetQuote2
+}
diff --git a/x11-plugins/gkrellstock/gkrellstock-0.5.1.ebuild b/x11-plugins/gkrellstock/gkrellstock-0.5.1.ebuild
new file mode 100644
index 000000000000..f376603e497f
--- /dev/null
+++ b/x11-plugins/gkrellstock/gkrellstock-0.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="Get Stock quotes plugin for Gkrellm2"
+HOMEPAGE="http://gkrellstock.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellstock/${P}.tar.gz"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ dev-perl/libwww-perl
+ dev-perl/Finance-Quote"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/s/S}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5-ldflags.patch
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
+ append-flags -fPIC
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install () {
+ gkrellm-plugin_src_install
+
+ dobin GetQuote2
+}
diff --git a/x11-plugins/gkrellstock/metadata.xml b/x11-plugins/gkrellstock/metadata.xml
new file mode 100644
index 000000000000..2644e2169ff0
--- /dev/null
+++ b/x11-plugins/gkrellstock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">gkrellstock</remote-id>
+ </upstream>
+</pkgmetadata>