summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 23:34:31 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-04 10:15:08 +0100
commitc33d07d7f29ebb4f195290c1ecf944c4b686de01 (patch)
treefd68b8ec62ea24ea16965c1054edc3af395cd9e4 /x11-plugins/gkrellstock
parentgkrellm-plugin.eclass: Remove built_with_use, EAPI 6 only (diff)
downloadgentoo-c33d07d7f29ebb4f195290c1ecf944c4b686de01.tar.gz
gentoo-c33d07d7f29ebb4f195290c1ecf944c4b686de01.tar.bz2
gentoo-c33d07d7f29ebb4f195290c1ecf944c4b686de01.zip
x11-plugins/gkrellstock: Eclass update
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-plugins/gkrellstock')
-rw-r--r--x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild b/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
index adbd9c88ad4f..3f7aff6dea76 100644
--- a/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
+++ b/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
@@ -1,34 +1,32 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit flag-o-matic gkrellm-plugin toolchain-funcs
DESCRIPTION="Get Stock quotes plugin for Gkrellm2"
HOMEPAGE="http://gkrellstock.sourceforge.net/"
SRC_URI="mirror://sourceforge/gkrellstock/${P}.tar.gz"
-SLOT="2"
LICENSE="GPL-2"
+SLOT="2"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
RDEPEND="
- app-admin/gkrellm[X]
+ app-admin/gkrellm:2[X]
dev-libs/glib:2
x11-libs/gtk+:2
dev-perl/libwww-perl
- dev-perl/Finance-Quote
-"
-DEPEND="${DEPEND}
- virtual/pkgconfig
-"
+ dev-perl/Finance-Quote"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
S="${WORKDIR}/${P/s/S}"
+PATCHES=( "${FILESDIR}"/${PN}-0.5-ldflags.patch )
-src_prepare() {
- default
- eapply "${FILESDIR}"/${PN}-0.5-ldflags.patch
+src_configure() {
append-cppflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
append-flags -fPIC
}