summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/gkrellsun/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/gkrellsun/files')
-rw-r--r--x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch13
-rw-r--r--x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch16
2 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..548039dd0e0b
--- /dev/null
+++ b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-Respect-LDFLAGS.patch
@@ -0,0 +1,13 @@
+diff --git a/src20/Makefile b/src20/Makefile
+index 3e8e62c..ef96fa2 100644
+--- a/src20/Makefile
++++ b/src20/Makefile
+@@ -16,6 +16,8 @@ FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+
++LFLAGS += $(LDFLAGS)
++
+ ifeq ($(enable_nls),1)
+ FLAGS += -DENABLE_NLS -DLOCALEDIR=\"$(LOCALEDIR)\"
+ export enable_nls
diff --git a/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch
new file mode 100644
index 000000000000..f47b96e88905
--- /dev/null
+++ b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch
@@ -0,0 +1,16 @@
+diff --git a/src20/gkrellsun.c b/src20/gkrellsun.c
+index f3adff5..0738bfc 100644
+--- a/src20/gkrellsun.c
++++ b/src20/gkrellsun.c
+@@ -1140,7 +1140,10 @@ cb_plugin_disabled()
+
+ save_sun_data();
+
+- if (textOptions.fontDesc) pango_font_description_free (textOptions.fontDesc);
++ if (textOptions.fontDesc) {
++ pango_font_description_free (textOptions.fontDesc);
++ textOptions.fontDesc = NULL;
++ }
+
+ /* This happens when user quits X Windows and gkrellm2 is still running */
+ if (colormap == NULL)