summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/gkrellweather/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/gkrellweather/files')
-rw-r--r--x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Move-GrabWeather.patch56
-rw-r--r--x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Respect-LDFLAGS.patch25
2 files changed, 81 insertions, 0 deletions
diff --git a/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Move-GrabWeather.patch b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Move-GrabWeather.patch
new file mode 100644
index 000000000000..5e2eb95e33fc
--- /dev/null
+++ b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Move-GrabWeather.patch
@@ -0,0 +1,56 @@
+From dc0fed370865b49e9bcb2db2eb7ff21adec904a8 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <lack@gentoo.org>
+Date: Tue, 24 Aug 2010 12:23:25 -0400
+Subject: [PATCH] Move GrabWeather script to $(PREFIX)/libexec/gkrellweather/
+
+This is to avoid a file collision with x11-misc/bbweather (Bug #333289)
+---
+ Makefile | 4 ++--
+ gkrellweather.c | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d6dc404..693b4f2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -38,13 +38,13 @@ install:
+ else \
+ install -D -c -s -m 644 gkrellweather.so $(PREFIX)/lib/gkrellm2/plugins/gkrellweather.so ; \
+ fi
+- install -c -m 755 GrabWeather $(PREFIX)/bin
++ install -D -c -m 755 GrabWeather $(PREFIX)/libexec/gkrellweather/
+
+ uninstall:
+ (cd po && ${MAKE} uninstall )
+ rm -f /usr/lib/gkrellm2/plugins/gkrellweather.so
+ rm -f $(PREFIX)/lib/gkrellm2/plugins/gkrellweather.so
+- rm -f $(PREFIX)/bin/GrabWeather
++ rm -f $(PREFIX)/libexec/gkrellweather/GrabWeather
+
+ dist:
+ rm -rf $(PKGNAME)-$(VERSION)
+diff --git a/gkrellweather.c b/gkrellweather.c
+index 1d4cf4e..224260a 100644
+--- a/gkrellweather.c
++++ b/gkrellweather.c
+@@ -721,7 +721,7 @@ apply_air_config (void)
+ options.station[1] = c[1];
+ options.station[2] = c[2];
+ options.station[3] = c[3];
+- snprintf(options.command, 512, PREFIX "/bin/GrabWeather %s", options.station);
++ snprintf(options.command, 512, PREFIX "/libexec/gkrellweather/GrabWeather %s", options.station);
+ options.command[511] = 0;
+ snprintf(options.filename, 512, "%s/.wmWeatherReports/%s.dat",
+ getenv("HOME"), options.station);
+@@ -986,7 +986,7 @@ read_default(void)
+ options.windspeed_unit = 1;
+ options.pressure_unit = 1;
+ strcpy(options.station, DEFAULT_STATION_ID);
+- snprintf(options.command, 512, "/usr/share/gkrellm/GrabWeather %s", options.station);
++ snprintf(options.command, 512, PREFIX "/libexec/gkrellweather/GrabWeather %s", options.station);
+ options.command[511] = 0;
+ snprintf(options.filename, 512, "%s/.wmWeatherReports/%s.dat",
+ getenv("HOME"), options.station);
+--
+1.7.2
+
diff --git a/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Respect-LDFLAGS.patch b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..9256cdd919c8
--- /dev/null
+++ b/x11-plugins/gkrellweather/files/gkrellweather-2.0.8-Respect-LDFLAGS.patch
@@ -0,0 +1,25 @@
+From 82c3a24ef34c5a5388ee9cc40126b3381fb8445a Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <lack@gentoo.org>
+Date: Wed, 11 Aug 2010 09:03:13 -0400
+Subject: [PATCH] Respect LDFLAGS
+
+---
+ Makefile | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d6dc404..46074ab 100644
+--- a/Makefile
++++ b/Makefile
+@@ -5,6 +5,8 @@ LIBS = `pkg-config gtk+-2.0 --libs`
+ LFLAGS = -shared
+ PREFIX = /usr/local
+
++LFLAGS += $(LDFLAGS)
++
+ LOCALEDIR := $(PREFIX)/share/locale
+
+ ifeq ($(enable_nls),1)
+--
+1.7.2
+