summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 23:34:32 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-04 10:15:48 +0100
commit952d48e964343c6354a9b1fe179eb86eb7277ce9 (patch)
tree11a8f502b400e13930b5fa3faf029452bb77b55c /x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild
parentx11-plugins/gkrellmss: Eclass update (diff)
downloadgentoo-952d48e964343c6354a9b1fe179eb86eb7277ce9.tar.gz
gentoo-952d48e964343c6354a9b1fe179eb86eb7277ce9.tar.bz2
gentoo-952d48e964343c6354a9b1fe179eb86eb7277ce9.zip
x11-plugins/gkrellweather: Eclass update
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild')
-rw-r--r--x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild b/x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild
index 2eab84402441..5e42ff7bb2ee 100644
--- a/x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild
+++ b/x11-plugins/gkrellweather/gkrellweather-2.0.8-r1.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit flag-o-matic gkrellm-plugin toolchain-funcs
DESCRIPTION="GKrellM2 Plugin that monitors a METAR station and displays weatherinfo"
HOMEPAGE="https://sites.google.com/site/makovick/gkrellm-plugins"
SRC_URI="https://sites.google.com/site/makovick/projects/${P}.tgz"
-SLOT="2"
LICENSE="GPL-2"
+SLOT="2"
KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
IUSE=""
RDEPEND="
- app-admin/gkrellm[X]
- >=dev-lang/perl-5.6.1
- >=net-misc/wget-1.5.3
-"
+ app-admin/gkrellm:2[X]
+ dev-lang/perl
+ net-misc/wget
+ x11-libs/gtk+:2"
DEPEND="
- >=sys-apps/sed-4.0.5
- virtual/pkgconfig
-"
+ ${RDEPEND}
+ virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-Respect-LDFLAGS.patch
@@ -29,14 +29,13 @@ PATCHES=(
"${FILESDIR}"/${P}-update-locations.patch
)
-src_prepare() {
- default
+src_configure() {
append-cflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
append-flags -fPIC
}
src_compile() {
- emake PREFIX=/usr CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+ emake PREFIX="${EPREFIX}"/usr CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install () {