summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/matchbox-applet-input-manager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/matchbox-applet-input-manager')
-rw-r--r--x11-plugins/matchbox-applet-input-manager/Manifest1
-rw-r--r--x11-plugins/matchbox-applet-input-manager/files/matchbox-applet-input-manager-0.6-sssh_debug.patch22
-rw-r--r--x11-plugins/matchbox-applet-input-manager/matchbox-applet-input-manager-0.6.ebuild42
-rw-r--r--x11-plugins/matchbox-applet-input-manager/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/x11-plugins/matchbox-applet-input-manager/Manifest b/x11-plugins/matchbox-applet-input-manager/Manifest
new file mode 100644
index 000000000000..9a671efd1784
--- /dev/null
+++ b/x11-plugins/matchbox-applet-input-manager/Manifest
@@ -0,0 +1 @@
+DIST mb-applet-input-manager-0.6.tar.bz2 198357 SHA256 552f7547f59cce5451d93258b1f0dfb6fa86a47d9eee72ae3e72cbfb0de50069
diff --git a/x11-plugins/matchbox-applet-input-manager/files/matchbox-applet-input-manager-0.6-sssh_debug.patch b/x11-plugins/matchbox-applet-input-manager/files/matchbox-applet-input-manager-0.6-sssh_debug.patch
new file mode 100644
index 000000000000..cd3f231bf0be
--- /dev/null
+++ b/x11-plugins/matchbox-applet-input-manager/files/matchbox-applet-input-manager-0.6-sssh_debug.patch
@@ -0,0 +1,22 @@
+Index: mb-applet-input-manager-0.6/mbinputmgr-tray.c
+===================================================================
+--- mb-applet-input-manager-0.6/mbinputmgr-tray.c {cset 0f2cc092-505c-44d3-bcdf-2b07f6f6942d}
++++ mb-applet-input-manager-0.6/mbinputmgr-tray.c {local clone}
+@@ -257,13 +257,17 @@ xevent_callback (MBTrayApp *app, XEvent
+ {
+ if (ev->type == ClientMessage)
+ {
++#ifdef DEBUG
+ printf("beep\n");
++#endif
+
+ XClientMessageEvent *cmev = (XClientMessageEvent *)&ev->xconfigure;
+
+ if (cmev->message_type == AtomIMActivate)
+ {
++#ifdef DEBUG
+ printf("beep\n");
++#endif
+
+ /* De Activate */
+ if (cmev->data.l[0] == 0 && mbinputmgr_method_active(Inpmgr_state))
diff --git a/x11-plugins/matchbox-applet-input-manager/matchbox-applet-input-manager-0.6.ebuild b/x11-plugins/matchbox-applet-input-manager/matchbox-applet-input-manager-0.6.ebuild
new file mode 100644
index 000000000000..1686b0487b76
--- /dev/null
+++ b/x11-plugins/matchbox-applet-input-manager/matchbox-applet-input-manager-0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator eutils
+
+MY_PN=${PN/matchbox/mb}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Matchbox panel tray app for managing software input methods"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${MY_PN}/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 ~arm ~hppa ppc x86"
+IUSE="debug"
+
+DEPEND=">=x11-libs/libmatchbox-1.5"
+
+RDEPEND="${DEPEND}
+ x11-wm/matchbox-panel"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-sssh_debug.patch
+}
+
+src_compile() {
+ econf $(use_enable debug) || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}
diff --git a/x11-plugins/matchbox-applet-input-manager/metadata.xml b/x11-plugins/matchbox-applet-input-manager/metadata.xml
new file mode 100644
index 000000000000..6a17403e0ad0
--- /dev/null
+++ b/x11-plugins/matchbox-applet-input-manager/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gpe</herd>
+</pkgmetadata>