summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-07 14:16:14 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-07 14:47:00 -0500
commit3e97501359124febd8bf9a38043bb48d57c67a45 (patch)
tree7c363633ff8ed0132833d25094ed7f07f64406f8 /x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild
parentx11-misc/xdotool: bump to EAPI 6, add maintainer-needed (diff)
downloadgentoo-3e97501359124febd8bf9a38043bb48d57c67a45.tar.gz
gentoo-3e97501359124febd8bf9a38043bb48d57c67a45.tar.bz2
gentoo-3e97501359124febd8bf9a38043bb48d57c67a45.zip
x11-plugins/pidgin-birthday-reminder: bump to EAPI 6, add maintainer-needed
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild b/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild
new file mode 100644
index 000000000000..06c207a41fd9
--- /dev/null
+++ b/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Plugin for Pidgin that reminds you of your buddies birthdays"
+HOMEPAGE="https://launchpad.net/pidgin-birthday-reminder"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="net-im/pidgin[gtk]"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -delete || die "la removal failed"
+ fi
+}