summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-06 23:31:47 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-06 23:31:47 +0200
commit70e472c4b06ac7d705f9ce33f2dae7189032613d (patch)
treed2d87b4fddcd4c7a98cc7584331e0d96f20c03b9 /x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
parentdev-lua/lua-zlib: Remove old (diff)
downloadgentoo-70e472c4b06ac7d705f9ce33f2dae7189032613d.tar.gz
gentoo-70e472c4b06ac7d705f9ce33f2dae7189032613d.tar.bz2
gentoo-70e472c4b06ac7d705f9ce33f2dae7189032613d.zip
x11-plugins/pidgin-xmpp-receipts: Version bump to 0.8
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild')
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
new file mode 100644
index 000000000000..ecb5f4ae29ff
--- /dev/null
+++ b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vcs-snapshot toolchain-funcs
+
+DESCRIPTION="Implementation of xmpp message delivery receipts (XEP-0184) for Pidgin"
+HOMEPAGE="https://github.com/noonien-d/pidgin-xmpp-receipts"
+SRC_URI="https://github.com/noonien-d/pidgin-xmpp-receipts/archive/release_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ GTK_PIDGIN_INCLUDES=$(pkg-config --cflags gtk+-2.0 pidgin)
+ $(tc-getCC) ${LDFLAGS} -shared ${CFLAGS} -fpic ${GTK_PIDGIN_INCLUDES} -o ${PN/pidgin-/}.so ${PN/pidgin-/}.c || die
+}
+
+src_install() {
+ PLUGIN_DIR_PIDGIN=$(pkg-config --variable=plugindir pidgin)
+ dodir "${PLUGIN_DIR_PIDGIN}"
+ insinto "${PLUGIN_DIR_PIDGIN}"
+ doins ${PN/pidgin-/}.so
+}