summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-06-13 11:03:46 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-06-13 11:04:24 +0200
commit58849640d851f78dedceb37e38e5bca8438e8299 (patch)
tree1059ec8d679b95f7434769b91e2ef861e4800361 /x11-plugins/wmXName
parentx11-plugins/wmpop3: fix build with -fno-common (diff)
downloadgentoo-58849640d851f78dedceb37e38e5bca8438e8299.tar.gz
gentoo-58849640d851f78dedceb37e38e5bca8438e8299.tar.bz2
gentoo-58849640d851f78dedceb37e38e5bca8438e8299.zip
x11-plugins/wmXName: fix build with -fno-common
Closes: https://bugs.gentoo.org/726272 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmXName')
-rw-r--r--x11-plugins/wmXName/files/wmXName-0.1-fno-common.patch35
-rw-r--r--x11-plugins/wmXName/wmXName-0.1-r1.ebuild2
2 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmXName/files/wmXName-0.1-fno-common.patch b/x11-plugins/wmXName/files/wmXName-0.1-fno-common.patch
new file mode 100644
index 000000000000..a4cb9c0cb043
--- /dev/null
+++ b/x11-plugins/wmXName/files/wmXName-0.1-fno-common.patch
@@ -0,0 +1,35 @@
+diff -Naur wmXName-0.01.orig/xutils.c wmXName-0.01/xutils.c
+--- wmXName-0.01.orig/xutils.c 2002-06-28 11:34:26.000000000 +0200
++++ wmXName-0.01/xutils.c 2020-06-13 11:02:20.393108819 +0200
+@@ -52,6 +52,11 @@
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
++Window Root;
++Window iconwin, win;
++int screen;
++int DisplayDepth;
+
+
+
+diff -Naur wmXName-0.01.orig/xutils.h wmXName-0.01/xutils.h
+--- wmXName-0.01.orig/xutils.h 2002-06-28 11:34:59.000000000 +0200
++++ wmXName-0.01/xutils.h 2020-06-13 11:02:25.886113159 +0200
+@@ -18,11 +18,11 @@
+ /*
+ * Global variable
+ */
+-Display *display;
+-Window Root;
+-Window iconwin, win;
+-int screen;
+-int DisplayDepth;
++extern Display *display;
++extern Window Root;
++extern Window iconwin, win;
++extern int screen;
++extern int DisplayDepth;
+
+
+
diff --git a/x11-plugins/wmXName/wmXName-0.1-r1.ebuild b/x11-plugins/wmXName/wmXName-0.1-r1.ebuild
index c812f1f76b89..793841b97984 100644
--- a/x11-plugins/wmXName/wmXName-0.1-r1.ebuild
+++ b/x11-plugins/wmXName/wmXName-0.1-r1.ebuild
@@ -25,6 +25,8 @@ RDEPEND="${COMMON_DEPEND}
>=dev-lang/perl-5.8.8-r5
>=www-client/lynx-2.8.6-r2"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
S="${WORKDIR}/${MY_P}"
src_prepare() {