summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-06-15 17:36:10 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-06-15 17:41:49 +0200
commite2970576097f155e2b102aa143e8ac6475a3b246 (patch)
treeaa82688f93f57db57761a56aa10507b5bbb61f77 /x11-plugins/wmacpi
parentapp-text/djvu: ppc stable wrt bug #536720 (diff)
downloadgentoo-e2970576097f155e2b102aa143e8ac6475a3b246.tar.gz
gentoo-e2970576097f155e2b102aa143e8ac6475a3b246.tar.bz2
gentoo-e2970576097f155e2b102aa143e8ac6475a3b246.zip
x11-plugins/wmacpi: 2.4 bump
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmacpi')
-rw-r--r--x11-plugins/wmacpi/Manifest1
-rw-r--r--x11-plugins/wmacpi/files/wmacpi-2.4-makefile.patch48
-rw-r--r--x11-plugins/wmacpi/wmacpi-2.4.ebuild24
3 files changed, 73 insertions, 0 deletions
diff --git a/x11-plugins/wmacpi/Manifest b/x11-plugins/wmacpi/Manifest
index ed795d99c085..faffd59389db 100644
--- a/x11-plugins/wmacpi/Manifest
+++ b/x11-plugins/wmacpi/Manifest
@@ -1 +1,2 @@
DIST wmacpi-2.3.tar.gz 39374 BLAKE2B bcf55a801fbc7b7c4484cc8987366786e1a1dbaf4d9ff6800975de14bd295ced774eaeedfe0c9da524b774de7633d5d250e7be55742fca7893f7314b8b4fe6fc SHA512 47c260989cd3fdb8d7ceadba19224e6350056741b03c6f1b73a38b06d7e471a08972dfbcaeacdcbc460bc19b0f952641eda75e11468b4d7155eecd07e1e14cd9
+DIST wmacpi-2.4.tar.gz 40265 BLAKE2B 5acd0b8506b762909893bb8d3ac28dc193166db67195bc14fb321b1d7f3a177cf60412b5d854d039ec0d6289dfefd9ea660a98e69a41148930b71437405ca65a SHA512 56a2967354a16f1ae03ee159dfe787a96c0d7ecf654852833ed71c7f65ca9a3717d9a582f2900a9fd925b0648ef5fcdf08cc4c68e78e75dedbd44a0a35ce752b
diff --git a/x11-plugins/wmacpi/files/wmacpi-2.4-makefile.patch b/x11-plugins/wmacpi/files/wmacpi-2.4-makefile.patch
new file mode 100644
index 000000000000..d772c99b6ed4
--- /dev/null
+++ b/x11-plugins/wmacpi/files/wmacpi-2.4-makefile.patch
@@ -0,0 +1,48 @@
+diff -Naur wmacpi-2.4.orig/Makefile wmacpi-2.4/Makefile
+--- wmacpi-2.4.orig/Makefile 2020-05-03 14:30:36.000000000 +0200
++++ wmacpi-2.4/Makefile 2020-06-15 17:32:49.549006100 +0200
+@@ -15,8 +15,8 @@
+ #OPT = -pg -g
+
+ CC := gcc
+-CFLAGS += $(OPT) -Wall -W -g -ansi -DWMACPI_VER='"$(WMACPI_VER)"'
+-LDFLAGS += $(OPT) -lX11 -ldockapp
++CFLAGS += -DWMACPI_VER='"$(WMACPI_VER)"'
++LIBS := -lX11 -ldockapp
+
+ WMSRC := wmacpi.c libacpi.c
+ HEADERS := libacpi.h
+@@ -28,7 +28,7 @@
+ doc_targets += wmacpi-cli.1
+ endif
+
+-PREFIX := /usr/local
++PREFIX := /usr
+
+ all: $(targets)
+
+@@ -39,7 +39,7 @@
+ -include $(WMOBJ:.o=.d)
+
+ wmacpi: $(WMOBJ)
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ # for the Debian package, we want to make building the command line tools
+ # optional. So, we hide all the necessary stuff here . . .
+@@ -49,13 +49,13 @@
+ -include $(CLOBJ:.o=.d)
+
+ wmacpi-cli: $(CLOBJ)
+- $(CC) $(LDFLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+ endif
+
+ # build per-file dependencies - note that -MM may not be supported
+ # in gcc versions older than 2.95.4, but most likely is.
+ %.d: %.c
+- gcc -MM $(CFLAGS) $< > $@
++ $(CC) -MM $(CFLAGS) $< > $@
+
+ clean:
+ rm -f TAGS *.o *~ trace *.out *.bb *.bbg
diff --git a/x11-plugins/wmacpi/wmacpi-2.4.ebuild b/x11-plugins/wmacpi/wmacpi-2.4.ebuild
new file mode 100644
index 000000000000..b2ad3b89acca
--- /dev/null
+++ b/x11-plugins/wmacpi/wmacpi-2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="DockApp ACPI status monitor for laptops"
+HOMEPAGE="https://www.dockapps.net/wmacpi"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc -sparc ~x86"
+
+DEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}