summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmblob
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmblob')
-rw-r--r--x11-plugins/wmblob/Manifest1
-rw-r--r--x11-plugins/wmblob/metadata.xml8
-rw-r--r--x11-plugins/wmblob/wmblob-1.0.3.ebuild35
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/wmblob/Manifest b/x11-plugins/wmblob/Manifest
new file mode 100644
index 000000000000..ffcdbe06b1de
--- /dev/null
+++ b/x11-plugins/wmblob/Manifest
@@ -0,0 +1 @@
+DIST wmblob_1.0.3.orig.tar.gz 180039 SHA256 d26850fe15e444817ed9996663427bd933a74d4e5591008a5a7c39d21e2583b2
diff --git a/x11-plugins/wmblob/metadata.xml b/x11-plugins/wmblob/metadata.xml
new file mode 100644
index 000000000000..aa3d72474b1f
--- /dev/null
+++ b/x11-plugins/wmblob/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="freshmeat">wmblob</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmblob/wmblob-1.0.3.ebuild b/x11-plugins/wmblob/wmblob-1.0.3.ebuild
new file mode 100644
index 000000000000..24d0aaf25e3d
--- /dev/null
+++ b/x11-plugins/wmblob/wmblob-1.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools multilib
+
+DESCRIPTION="a fancy but useless dockapp with moving blobs"
+HOMEPAGE="http://freshmeat.net/projects/wmblob"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+DOCS="AUTHORS ChangeLog NEWS README doc/how_it_works"
+
+src_prepare() {
+ sed -i \
+ -e "s:-O2:${CFLAGS}:g" \
+ -e "s:\$x_libraries:/usr/$(get_libdir):" \
+ configure.ac || die
+
+ eautoreconf
+}