summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmbutton/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmbutton/files')
-rw-r--r--x11-plugins/wmbutton/files/sample.wmbutton43
-rw-r--r--x11-plugins/wmbutton/files/wmbutton-0.6.1-Makefile.patch27
-rw-r--r--x11-plugins/wmbutton/files/wmbutton-0.7.0-Makefile.patch26
3 files changed, 96 insertions, 0 deletions
diff --git a/x11-plugins/wmbutton/files/sample.wmbutton b/x11-plugins/wmbutton/files/sample.wmbutton
new file mode 100644
index 000000000000..a4177a24e081
--- /dev/null
+++ b/x11-plugins/wmbutton/files/sample.wmbutton
@@ -0,0 +1,43 @@
+# Buttons are numbered as follows
+# Left 1 2 3 Middle 11 12 13 Right 21 22 23
+# button 4 5 6 button 14 15 16 button 24 25 26
+# 7 8 9 17 18 19 27 28 29
+#
+
+1 mozilla &
+11 firefox &
+21 opera &
+
+2 evolution &
+12 mozilla -mail &
+22 gftp &
+
+3 xterm -T 'xterm' &
+13 Eterm -T 'Eterm' &
+23 aterm -T 'Aterm' &
+
+4 psi &
+14 gaim &
+24 kadu &
+
+5 gentoo &
+15 xterm -T 'Midnight Commander' -e mc &
+25 xffm &
+
+6 ooffice &
+16 gnumeric &
+26 acroread &
+
+7 xmms &
+17 gmplayer &
+27 audacity &
+
+8 gimp-2.0 &
+18 sodipodi &
+28 kpaint &
+
+9 kghostview &
+19 ggv &
+29 xpdf &
+# The above don't need to be in any particular order.
+# Repeated entries should be ignored
diff --git a/x11-plugins/wmbutton/files/wmbutton-0.6.1-Makefile.patch b/x11-plugins/wmbutton/files/wmbutton-0.6.1-Makefile.patch
new file mode 100644
index 000000000000..7654c8cd40e7
--- /dev/null
+++ b/x11-plugins/wmbutton/files/wmbutton-0.6.1-Makefile.patch
@@ -0,0 +1,27 @@
+diff -ur wmbutton-0.6.1.orig/Makefile wmbutton-0.6.1/Makefile
+--- wmbutton-0.6.1.orig/Makefile 2005-01-16 17:12:54.000000000 +0200
++++ wmbutton-0.6.1/Makefile 2008-01-13 08:15:02.000000000 +0200
+@@ -1,19 +1,17 @@
+-INCLUDES =-I/usr/X11R6/include/X11 -I/usr/local/include -I/usr/include/X11R6/X11
+-LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
++INCLUDES =-I/usr/include/X11
+ LIBS = -lX11 -lXpm -lXext
++CC = gcc
+
+ TARGET = wmbutton
+ OBJECTS = wmbutton.o wmb_libs.o
+
+-CFLAGS += -c -Wall -O2
+-
+ all: ${TARGET} tags
+
+ .c.o:
+- gcc ${CFLAGS} ${INCLUDES} $< -o $*.o
++ ${CC} -c ${CFLAGS} ${INCLUDES} $< -o $*.o
+
+ ${TARGET}: ${OBJECTS}
+- gcc -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
++ ${CC} ${LDFLAGS} ${OBJECTS} ${LIBS} -o ${TARGET}
+
+ clean::
+ for i in ${OBJECTS}; do if [ -e $$i ] ; then rm $$i; fi; done
diff --git a/x11-plugins/wmbutton/files/wmbutton-0.7.0-Makefile.patch b/x11-plugins/wmbutton/files/wmbutton-0.7.0-Makefile.patch
new file mode 100644
index 000000000000..f9197842b44a
--- /dev/null
+++ b/x11-plugins/wmbutton/files/wmbutton-0.7.0-Makefile.patch
@@ -0,0 +1,26 @@
+--- Makefile.orig 2014-10-06 15:20:41.300883734 +0200
++++ Makefile 2014-10-06 15:22:08.936939085 +0200
+@@ -1,6 +1,6 @@
+ INCLUDES =-I/usr/include -I/usr/local/include
+-LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
+ LIBS = -lX11 -lXpm -lXext
++CC = gcc
+
+ TARGET = wmbutton
+ OBJECTS = wmbutton.o wmb_libs.o
+@@ -14,13 +14,11 @@
+ INSTALL_PROGRAM = $(INSTALL) -p -o root -g root -m 755
+ INSTALL_FILE = $(INSTALL) -p -o root -g root -m 644
+
+-CFLAGS += -Wall -O2
+-
+ .c.o:
+- gcc -c ${CFLAGS} ${INCLUDES} $< -o $*.o
++ ${CC} -c ${CFLAGS} ${INCLUDES} $< -o $*.o
+
+ ${TARGET}: ${OBJECTS}
+- gcc -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
++ ${CC} ${LDFLAGS} ${OBJECTS} ${LIBS} -o ${TARGET}
+
+ clean::
+ for i in ${OBJECTS}; do if [ -e $$i ] ; then rm $$i; fi; done