summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-08-24 13:50:45 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2015-08-24 13:50:45 +0200
commita4a8d61d387c18ad6860d23edb8720418d7e1959 (patch)
tree8f6bc46022cb54721d30f08ffffc8c80e1a4ae11 /x11-plugins/wmcalc/wmcalc-0.6.ebuild
parentEnable https for all google URIs (diff)
downloadgentoo-a4a8d61d387c18ad6860d23edb8720418d7e1959.tar.gz
gentoo-a4a8d61d387c18ad6860d23edb8720418d7e1959.tar.bz2
gentoo-a4a8d61d387c18ad6860d23edb8720418d7e1959.zip
x11-plugins/wmcalc: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-plugins/wmcalc/wmcalc-0.6.ebuild')
-rw-r--r--x11-plugins/wmcalc/wmcalc-0.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/wmcalc/wmcalc-0.6.ebuild b/x11-plugins/wmcalc/wmcalc-0.6.ebuild
new file mode 100644
index 000000000000..9f5c7c8fe7b5
--- /dev/null
+++ b/x11-plugins/wmcalc/wmcalc-0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="A WindowMaker DockApp calculator"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmcalc"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ dodoc README
+}