summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-08 16:11:49 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-07-19 15:25:23 +0200
commit1f4dada784da01b4a9cff7cff3ef44045f245c7d (patch)
treefb99f8d32bcc4d060153dc6ab9071908e0a9639e /x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild
parentx11-plugins/wmcalc: add EAPI7 ebuild (diff)
downloadgentoo-1f4dada784da01b4a9cff7cff3ef44045f245c7d.tar.gz
gentoo-1f4dada784da01b4a9cff7cff3ef44045f245c7d.tar.bz2
gentoo-1f4dada784da01b4a9cff7cff3ef44045f245c7d.zip
x11-plugins/wmcalendar: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild')
-rw-r--r--x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild b/x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild
new file mode 100644
index 000000000000..bda76dc009c0
--- /dev/null
+++ b/x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="a calendar dockapp"
+HOMEPAGE="http://wmcalendar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/libical
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ../{BUGS,CHANGES,HINTS,README,TODO} )
+
+S=${WORKDIR}/${P}/Src
+
+PATCHES=( "${FILESDIR}"/${P}-exit-sin-and-cos.patch
+ "${FILESDIR}"/${P}-rename_kill_func.patch
+ "${FILESDIR}"/${P}-ical.patch )
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+}