summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmfire
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmfire')
-rw-r--r--x11-plugins/wmfire/Manifest1
-rw-r--r--x11-plugins/wmfire/files/wmfire-1.2.3-stringh.patch11
-rw-r--r--x11-plugins/wmfire/files/wmfire-1.2.4-lastprocessor_SMP.patch130
-rw-r--r--x11-plugins/wmfire/files/wmfire-1.2.4-no_display.patch19
-rw-r--r--x11-plugins/wmfire/metadata.xml13
-rw-r--r--x11-plugins/wmfire/wmfire-1.2.4-r2.ebuild42
6 files changed, 216 insertions, 0 deletions
diff --git a/x11-plugins/wmfire/Manifest b/x11-plugins/wmfire/Manifest
new file mode 100644
index 000000000000..33cc00f2fdc1
--- /dev/null
+++ b/x11-plugins/wmfire/Manifest
@@ -0,0 +1 @@
+DIST wmfire-1.2.4.tar.gz 91144 SHA256 e38b508519faf132273a9eaf75db56f1b14a5912667dd6843fc902d4a0ca2f80
diff --git a/x11-plugins/wmfire/files/wmfire-1.2.3-stringh.patch b/x11-plugins/wmfire/files/wmfire-1.2.3-stringh.patch
new file mode 100644
index 000000000000..a0fcfdcdc6e3
--- /dev/null
+++ b/x11-plugins/wmfire/files/wmfire-1.2.3-stringh.patch
@@ -0,0 +1,11 @@
+diff -ur wmfire-1.2.3.orig/src/session.c wmfire-1.2.3/src/session.c
+--- wmfire-1.2.3.orig/src/session.c 2005-12-04 12:39:16.000000000 +0200
++++ wmfire-1.2.3/src/session.c 2008-01-12 13:26:04.000000000 +0200
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <pwd.h>
+
diff --git a/x11-plugins/wmfire/files/wmfire-1.2.4-lastprocessor_SMP.patch b/x11-plugins/wmfire/files/wmfire-1.2.4-lastprocessor_SMP.patch
new file mode 100644
index 000000000000..2b389fecdd68
--- /dev/null
+++ b/x11-plugins/wmfire/files/wmfire-1.2.4-lastprocessor_SMP.patch
@@ -0,0 +1,130 @@
+--- wmfire-1.2.4/src/wmfire.c.orig 2005-12-04 11:39:16.000000000 +0100
++++ wmfire-1.2.4/src/wmfire.c 2012-02-27 15:48:05.136807354 +0100
+@@ -63,6 +63,10 @@
+ #define FIRE_NET 3
+ #define FIRE_FILE 4
+
++/* wbk 20120220 - cleaning up "next cpu" logic */
++#define CPU_AV -1 /* needs to be 1st CPU - 1 */
++#define CPU_NEXT -2 /* arbitrary but must be < CPU_AV */
++
+ #define NET_SPD_PPP 56
+ #define NET_SPD_ETH 100
+
+@@ -104,7 +108,8 @@
+ int update_mem();
+ int update_net();
+ int update_file();
+-int change_cpu(int);
++void change_cpu(int);
++int more_cpus();
+ void change_flame(int);
+ GdkCursor *setup_cursor();
+ void burn_spot(int, int, int);
+@@ -130,8 +135,7 @@
+
+ int monitor = FIRE_CPU;
+ int load = 100;
+-int cpu_av = 1;
+-int cpu_id = 0;
++int cpu_id = CPU_AV; /* wbk - special value instead of separate flag */
+ int cpu_nice = 1;
+ char net_dev[16] = "ppp0";
+ int net_spd = 0;
+@@ -224,8 +228,15 @@
+ next = 0;
+
+ if (!lock) {
+- if (monitor == FIRE_CPU && change_cpu(-1))
+- monitor = FIRE_MEM;
++ if (monitor == FIRE_CPU)
++ {
++ /* First, check if we have more CPU's to monitor. If none, *
++ * move along to FIRE_MEM. Regardless, after this check, we *
++ * call change_cpu() to increment or reset CPU number. */
++ if (!more_cpus())
++ monitor = FIRE_MEM;
++ change_cpu(CPU_NEXT);
++ }
+ else if (monitor == FIRE_MEM)
+ monitor = FIRE_NET;
+ else if (monitor == FIRE_NET)
+@@ -285,7 +296,7 @@
+
+ glibtop_get_cpu(&cpu);
+
+- if (cpu_av) {
++ if (cpu_id == CPU_AV) {
+ if (cpu_nice)
+ load = cpu.user + cpu.nice + cpu.sys;
+ else
+@@ -383,30 +394,46 @@
+ /* Change CPU monitor */
+ /******************************************/
+
+-int
++void
+ change_cpu(int which)
+ {
+- glibtop_cpu cpu;
++ /* wbk 20120221 - Changed return type to void. Use more_cpus() *
++ * for tests instead. Mixing test logic with changing the CPU *
++ * was causing CPU's to be skipped in calling function. */
+
++ /* wbk - Even though we never use the cpu struct, I think this *
++ * call may be necessary to set up glibtop_global_server? */
++ glibtop_cpu cpu;
+ glibtop_get_cpu(&cpu);
+
+ /* This should work, but I have a lonely uniprocessor system */
++ /* wbk - tested with a quad core. */
+
+- if (which >= 0) {
++ if (which != CPU_NEXT) /* was run with command-line CPU specifier */
+ cpu_id = which;
+- cpu_av = 0;
+- } else {
+- cpu_id++;
+- cpu_av = 0;
+- }
++ else /* negative value "special case" for which */
++ cpu_id++;
+
+- if (cpu_id >= glibtop_global_server->ncpu || cpu_id >= GLIBTOP_NCPU) {
+- cpu_id = 0;
+- cpu_av = 1;
+- return 1;
+- }
++ /* Since we already incremented cpu_id, we are comparing a *
++ * 1-index with 0-index value essentially. But since GLIBTOP_NCPU *
++ * is 1-indexed, keep >= for it. (a bit of an oversimplification: *
++ * cpu_id is still definitely regarded as 0-indexed elsewhere. We *
++ * index an array with it later, so this is important) */
++ if (cpu_id > glibtop_global_server->ncpu || cpu_id >= GLIBTOP_NCPU)
++ cpu_id = CPU_AV;
+
+- return 0;
++ return;
++}
++
++int
++more_cpus()
++{
++ /* returns positive if next CPU would be valid, Negative if *
++ * already monitoring highest-numbered CPU or if more cores than *
++ * glibtop supports. */
++ int next_cpu = cpu_id + 1;
++ return !(next_cpu > glibtop_global_server->ncpu
++ || next_cpu >= GLIBTOP_NCPU);
+ }
+
+ /******************************************/
+@@ -494,7 +521,7 @@
+ if (proximity++ > 100) {
+
+ if (monitor == FIRE_CPU) {
+- if (cpu_av) {
++ if (cpu_id == CPU_AV) {
+ /* Horizontal bar for average cpu */
+ memset(&bm.cmap[27 * XMAX + 20], 255, 16);
+ memset(&bm.cmap[28 * XMAX + 20], 255, 16);
diff --git a/x11-plugins/wmfire/files/wmfire-1.2.4-no_display.patch b/x11-plugins/wmfire/files/wmfire-1.2.4-no_display.patch
new file mode 100644
index 000000000000..a2540a247cf6
--- /dev/null
+++ b/x11-plugins/wmfire/files/wmfire-1.2.4-no_display.patch
@@ -0,0 +1,19 @@
+--- src/wmfire.c.orig 2010-06-28 23:53:35.000000000 +0200
++++ src/wmfire.c 2010-06-28 23:54:35.000000000 +0200
+@@ -150,6 +150,8 @@
+ int
+ main(int argc, char **argv)
+ {
++ /* This is needed to proper dockapp work on >=GTK+-2.18 */
++ setenv("GDK_NATIVE_WINDOWS", "1", 0);
+ GdkEvent *event;
+ GdkCursor *cursor;
+ int i;
+@@ -632,6 +634,7 @@
+
+ /* Moved after gdk_window_show due to change in GTK 2.4 */
+ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++ gdk_window_show(bm.iconwin);
+
+ if (bm.x > 0 || bm.y > 0)
+ gdk_window_move(bm.win, bm.x, bm.y);
diff --git a/x11-plugins/wmfire/metadata.xml b/x11-plugins/wmfire/metadata.xml
new file mode 100644
index 000000000000..93b239563828
--- /dev/null
+++ b/x11-plugins/wmfire/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+wmfire is an eye-candy dock applet for Window Maker that displays generated
+fire, possibly according to how much load the system is experiencing, or from a
+number somewhere in a file. wmfire requires very little CPU.
+</longdescription>
+<use>
+ <flag name='session'>Enable session management</flag>
+</use>
+</pkgmetadata>
diff --git a/x11-plugins/wmfire/wmfire-1.2.4-r2.ebuild b/x11-plugins/wmfire/wmfire-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..f2091677f5a5
--- /dev/null
+++ b/x11-plugins/wmfire/wmfire-1.2.4-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Load monitoring dockapp displaying dancing flame"
+HOMEPAGE="http://www.swanson.ukfsn.org/#wmfire"
+SRC_URI="http://www.swanson.ukfsn.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="session"
+
+RDEPEND="x11-libs/gtk+:2
+ gnome-base/libgtop:2
+ x11-libs/libX11
+ x11-libs/libXext
+ session? ( x11-libs/libSM
+ x11-libs/libICE )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.3-stringh.patch
+ epatch "${FILESDIR}"/${P}-no_display.patch
+ epatch "${FILESDIR}"/${P}-lastprocessor_SMP.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable session)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ALL_I_GET_IS_A_GREY_BOX AUTHORS ChangeLog NEWS README
+}