summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmifinfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmifinfo')
-rw-r--r--x11-plugins/wmifinfo/Manifest2
-rw-r--r--x11-plugins/wmifinfo/metadata.xml5
-rw-r--r--x11-plugins/wmifinfo/wmifinfo-0.09.ebuild35
-rw-r--r--x11-plugins/wmifinfo/wmifinfo-0.10.ebuild35
4 files changed, 77 insertions, 0 deletions
diff --git a/x11-plugins/wmifinfo/Manifest b/x11-plugins/wmifinfo/Manifest
new file mode 100644
index 000000000000..0940e765e86c
--- /dev/null
+++ b/x11-plugins/wmifinfo/Manifest
@@ -0,0 +1,2 @@
+DIST wmifinfo-0.09.tgz 16098 SHA256 d1ce49630cf716e17afa1d3fd5a0816f4ba092f2b1e84593784d084fd261d7df
+DIST wmifinfo-0.10.tar.gz 17415 SHA256 3f990ccfbd24e01d9f2ca13a5881c6b122e5dd29b10c2778199fc6502ee4c2e3 SHA512 84c0a30eba12bb9e969bea1e7ac7a37c3172cc93f6bb87ee9a9ba0cba5d814ea3550f84626d329e648abe1d834b864fe9f050a411b6063e2c1745dfec1ee96d5 WHIRLPOOL 745bb4ee7bf9d60427e64500eeef577df27d37ac68566d1b07d3ecc93a6a2cc04a0e527dbb4670dcac0fdc9060d229982f48beff860f4ed938596865968487b6
diff --git a/x11-plugins/wmifinfo/metadata.xml b/x11-plugins/wmifinfo/metadata.xml
new file mode 100644
index 000000000000..ebfeafcdb873
--- /dev/null
+++ b/x11-plugins/wmifinfo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmifinfo/wmifinfo-0.09.ebuild b/x11-plugins/wmifinfo/wmifinfo-0.09.ebuild
new file mode 100644
index 000000000000..041d5a9e85ef
--- /dev/null
+++ b/x11-plugins/wmifinfo/wmifinfo-0.09.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp for monitoring network interfaces"
+HOMEPAGE="http://zevv.nl/play/code/wmifinfo"
+SRC_URI="http://zevv.nl/play/code/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:-O2:${CFLAGS}:" "${S}"/Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getCC) ${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc README || die
+}
diff --git a/x11-plugins/wmifinfo/wmifinfo-0.10.ebuild b/x11-plugins/wmifinfo/wmifinfo-0.10.ebuild
new file mode 100644
index 000000000000..9e0327b6127d
--- /dev/null
+++ b/x11-plugins/wmifinfo/wmifinfo-0.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp for monitoring network interfaces"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmifinfo"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/dockapps
+
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ dodoc README Changelog
+}