summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmping
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmping')
-rw-r--r--x11-plugins/wmping/Manifest1
-rw-r--r--x11-plugins/wmping/files/wmping-0.2.1-format-security.patch38
-rw-r--r--x11-plugins/wmping/metadata.xml8
-rw-r--r--x11-plugins/wmping/wmping-0.2.1.ebuild43
4 files changed, 90 insertions, 0 deletions
diff --git a/x11-plugins/wmping/Manifest b/x11-plugins/wmping/Manifest
new file mode 100644
index 000000000000..442527dc0dae
--- /dev/null
+++ b/x11-plugins/wmping/Manifest
@@ -0,0 +1 @@
+DIST wmping-0.2.1.tar.gz 100059 SHA256 8d10c77839f087add2c3b2f483585ede92f4c57a4a18262c74406591877a3c33 SHA512 c13a4906810d7513fe3e1e88a77846a5b0a299180f858f755a2fe602eaab802e77062d29e767e4d5c28e45bc6ce1431418cc71ee26c3c8fc5521280999bb9351 WHIRLPOOL f42b9a35c3b9d45116cbef6d3644310b05961e00fab96674acd13eb7193681223892dd10f586abf2ee829b29ca432095f1a7b8c92516813390df0194036b6997
diff --git a/x11-plugins/wmping/files/wmping-0.2.1-format-security.patch b/x11-plugins/wmping/files/wmping-0.2.1-format-security.patch
new file mode 100644
index 000000000000..cc9976d04ad2
--- /dev/null
+++ b/x11-plugins/wmping/files/wmping-0.2.1-format-security.patch
@@ -0,0 +1,38 @@
+--- wmping.c.orig 2015-08-06 15:03:32.407526918 +0200
++++ wmping.c 2015-08-06 15:03:56.907978079 +0200
+@@ -237,7 +237,7 @@
+ if(strcmp(tokens[1],"="))
+ {
+ sprintf(str_err, "Not correct format of configuration file ( %s ): line %u", cfgfile, lineN);
+- fprintf(stderr, str_err);
++ fprintf(stderr, "%s", str_err);
+ exit(-1);
+ }
+
+@@ -288,7 +288,7 @@
+ else
+ {
+ sprintf(str_err, "Not correct format of configuration file ( %s ): line %u", cfgfile, lineN);
+- fprintf(stderr, str_err);
++ fprintf(stderr, "%s", str_err);
+ exit(-1);
+
+ }
+@@ -297,7 +297,7 @@
+ else
+ {
+ sprintf(str_err, "Error open configuration file ( %s ): %s", cfgfile, strerror(errno));
+- fprintf(stderr, str_err);
++ fprintf(stderr, "%s", str_err);
+ fprintf(stderr, "\n Create default configuration file\n");
+ createDefaultCfg(cfgfile);
+ }
+@@ -305,7 +305,7 @@
+ else
+ {
+ sprintf(str_err, "Error open configuration file ( %s ): %s", cfgfile, strerror(errno));
+- fprintf(stderr, str_err);
++ fprintf(stderr, "%s", str_err);
+ fprintf(stderr, "\n Create default configuration file\n");
+ createDefaultCfg(cfgfile);
+ }
diff --git a/x11-plugins/wmping/metadata.xml b/x11-plugins/wmping/metadata.xml
new file mode 100644
index 000000000000..96baaa510b9c
--- /dev/null
+++ b/x11-plugins/wmping/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">wmping</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmping/wmping-0.2.1.ebuild b/x11-plugins/wmping/wmping-0.2.1.ebuild
new file mode 100644
index 000000000000..338046efd4f4
--- /dev/null
+++ b/x11-plugins/wmping/wmping-0.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="a simple host status monitoring dockapp"
+HOMEPAGE="http://sourceforge.net/projects/wmping"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+suid"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libICE
+ x11-libs/libXt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}
+
+src_install() {
+ if use suid; then
+ emake DESTDIR="${D}" install
+ else
+ dosbin ${PN}
+ fi
+
+ doman ${PN}.1
+ dodoc AUTHORS CHANGES README
+}
+
+pkg_postinst() {
+ use suid || ewarn "warning, ${PN} needs to be executed as root."
+}