summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-12-03 11:39:50 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-12-03 11:40:09 +0100
commit9b28449fa0c087396229634de43b49224cb5b430 (patch)
tree6189d154fe48f877a4c11bae9fd5d57b645bc9b5 /x11-plugins/wmsystray
parentapp-admin/bitwarden-desktop-bin: version bump 1.23.1 (diff)
downloadgentoo-9b28449fa0c087396229634de43b49224cb5b430.tar.gz
gentoo-9b28449fa0c087396229634de43b49224cb5b430.tar.bz2
gentoo-9b28449fa0c087396229634de43b49224cb5b430.zip
x11-plugins/wmsystray: properly set CC
Also fix incorrect return statement Closes: https://bugs.gentoo.org/743073 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmsystray')
-rw-r--r--x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch30
-rw-r--r--x11-plugins/wmsystray/files/wmsystray-0.1.1-return-type.patch12
-rw-r--r--x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild16
3 files changed, 39 insertions, 19 deletions
diff --git a/x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch b/x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch
index 19afa355b229..ab754703962b 100644
--- a/x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch
+++ b/x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch
@@ -1,6 +1,6 @@
-diff -ur wmsystray-0.1.1/Makefile wmsystray-0.1.1.new/Makefile
---- wmsystray-0.1.1/Makefile 2004-03-01 05:35:47.000000000 +0100
-+++ wmsystray-0.1.1.new/Makefile 2007-06-30 18:09:59.000000000 +0200
+diff -Naur wmsystray-0.1.1.orig/Makefile wmsystray-0.1.1/Makefile
+--- wmsystray-0.1.1.orig/Makefile 2004-03-01 05:35:47.000000000 +0100
++++ wmsystray-0.1.1/Makefile 2020-12-03 11:22:13.786357942 +0100
@@ -1,13 +1,14 @@
prefix=/usr
bindir = ${prefix}/bin
@@ -19,21 +19,29 @@ diff -ur wmsystray-0.1.1/Makefile wmsystray-0.1.1.new/Makefile
clean:
make -C xembed clean
-diff -ur wmsystray-0.1.1/wmsystray/Makefile wmsystray-0.1.1.new/wmsystray/Makefile
---- wmsystray-0.1.1/wmsystray/Makefile 2004-03-01 04:54:44.000000000 +0100
-+++ wmsystray-0.1.1.new/wmsystray/Makefile 2007-06-30 18:09:59.000000000 +0200
-@@ -1,7 +1,7 @@
+diff -Naur wmsystray-0.1.1.orig/wmsystray/Makefile wmsystray-0.1.1/wmsystray/Makefile
+--- wmsystray-0.1.1.orig/wmsystray/Makefile 2004-03-01 04:54:44.000000000 +0100
++++ wmsystray-0.1.1/wmsystray/Makefile 2020-12-03 11:26:57.544595661 +0100
+@@ -1,14 +1,13 @@
include ../Rules.make
- CC = gcc
+-CC = gcc
-CFLAGS = ${X11CFLAGS} -DTRACE_LEVEL=${TRACE_LEVEL} -I../xembed -Wall -g
+CFLAGS = ${X11CFLAGS} -DTRACE_LEVEL=${TRACE_LEVEL} -I../xembed -g ${EXTRACFLAGS}
LDFLAGS = ${X11LDFLAGS} -lXpm
OBJS = main.o ui.o systray.o xpms.o
-diff -ur wmsystray-0.1.1/xembed/Makefile wmsystray-0.1.1.new/xembed/Makefile
---- wmsystray-0.1.1/xembed/Makefile 2004-03-01 04:54:44.000000000 +0100
-+++ wmsystray-0.1.1.new/xembed/Makefile 2007-06-30 18:09:59.000000000 +0200
+ XEMBED_OBJS = ../xembed/xembed.o
+
+ wmsystray: ${OBJS} ${XEMBED_OBJS}
+- gcc ${OBJS} ${XEMBED_OBJS} -o wmsystray ${LDFLAGS}
++ ${CC} ${OBJS} ${XEMBED_OBJS} -o wmsystray ${LDFLAGS}
+
+ clean:
+ rm -f wmsystray ${OBJS}
+diff -Naur wmsystray-0.1.1.orig/xembed/Makefile wmsystray-0.1.1/xembed/Makefile
+--- wmsystray-0.1.1.orig/xembed/Makefile 2004-03-01 04:54:44.000000000 +0100
++++ wmsystray-0.1.1/xembed/Makefile 2020-12-03 11:22:13.786357942 +0100
@@ -1,6 +1,6 @@
include ../Rules.make
diff --git a/x11-plugins/wmsystray/files/wmsystray-0.1.1-return-type.patch b/x11-plugins/wmsystray/files/wmsystray-0.1.1-return-type.patch
new file mode 100644
index 000000000000..aa2c6539b81b
--- /dev/null
+++ b/x11-plugins/wmsystray/files/wmsystray-0.1.1-return-type.patch
@@ -0,0 +1,12 @@
+diff -Naur wmsystray-0.1.1.orig/wmsystray/systray.c wmsystray-0.1.1/wmsystray/systray.c
+--- wmsystray-0.1.1.orig/wmsystray/systray.c 2004-03-01 04:54:50.000000000 +0100
++++ wmsystray-0.1.1/wmsystray/systray.c 2020-12-03 11:30:36.661776579 +0100
+@@ -338,7 +338,7 @@
+ XReparentWindow (main_disp, embed_wind,
+ DefaultRootWindow(main_disp), 0, 0);
+ TRACE((stderr, "REJECTED!\n"));
+- return;
++ return 1;
+ }
+
+ XSelectInput (main_disp, embed_wind, StructureNotifyMask |
diff --git a/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
index 4756f31445fd..926644e2d5b7 100644
--- a/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
+++ b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop
+inherit desktop toolchain-funcs
DESCRIPTION="Window Maker dock app that provides a system tray for GNOME/KDE applications"
HOMEPAGE="https://github.com/bbidulock/wmsystray"
@@ -17,11 +17,11 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc ~sparc x86"
-# Let's honour Gentoo CFLAGS and use correct install program
-# Fix for #61704, cannot compile with gcc 3.4.1:
-# it's a trivial change and does not affect other compilers...
-PATCHES=( "${FILESDIR}/${P}-Makefile.patch"
- "${FILESDIR}/${P}-gcc-3.4.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-Makefile.patch"
+ "${FILESDIR}/${P}-gcc-3.4.patch"
+ "${FILESDIR}/${P}-return-type.patch"
+)
DOCS=( README HACKING AUTHORS )
@@ -35,7 +35,7 @@ src_prepare() {
}
src_compile() {
- emake EXTRACFLAGS="${CFLAGS}"
+ emake CC="$(tc-getCC)" EXTRACFLAGS="${CFLAGS}"
}
src_install() {