summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmtz/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmtz/files')
-rw-r--r--x11-plugins/wmtz/files/wmtz-0.7.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-plugins/wmtz/files/wmtz-0.7.patch b/x11-plugins/wmtz/files/wmtz-0.7.patch
new file mode 100644
index 000000000000..adb5c68f1b6c
--- /dev/null
+++ b/x11-plugins/wmtz/files/wmtz-0.7.patch
@@ -0,0 +1,48 @@
+diff -ur wmtz-0.7.orig/wmtz/Makefile wmtz-0.7/wmtz/Makefile
+--- wmtz-0.7.orig/wmtz/Makefile 2001-03-11 15:57:59.000000000 +0200
++++ wmtz-0.7/wmtz/Makefile 2008-01-12 15:24:29.000000000 +0200
+@@ -1,5 +1,5 @@
+ CC = gcc
+-LIBDIR = -L/usr/X11R6/lib
++LIBDIR = -L/usr/lib
+ LIBS = -lXpm -lXext -lX11 -lm
+ FLAGS = -O2
+ DESTDIR = /usr/local
+@@ -10,7 +10,7 @@
+
+
+ .c.o:
+- $(CC) -I/usr/X11R6/include $(FLAGS) -c -Wall $< -o $*.o
++ $(CC) -I/usr/include $(FLAGS) -c -Wall $< -o $*.o
+
+ wmtz: $(OBJS)
+ $(CC) $(FLAGS) -o wmtz $^ -lXext $(LIBDIR) $(LIBS)
+diff -ur wmtz-0.7.orig/wmtz/wmtz.c wmtz-0.7/wmtz/wmtz.c
+--- wmtz-0.7.orig/wmtz/wmtz.c 2001-04-16 22:26:34.000000000 +0300
++++ wmtz-0.7/wmtz/wmtz.c 2008-01-12 15:17:37.000000000 +0200
+@@ -51,8 +51,7 @@
+ #define STRSIZE 10
+ #define LMST 1
+ #define GMST 0
+-#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7
+-http://www.geocities.com/jl1n/wmtz/wmtz.html\""
++#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7\nhttp://www.geocities.com/jl1n/wmtz/wmtz.html\""
+
+
+ /*
+@@ -479,6 +478,7 @@
+ but_stat = -1;
+ break;
+ default:
++ break;
+ }
+ }
+
+@@ -529,6 +529,7 @@
+ exit(0);
+ break;
+ default:
++ break;
+ }
+ return;
+ }