summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-07-03 22:22:37 -0400
committerAaron Bauman <bman@gentoo.org>2020-07-03 22:24:06 -0400
commit17ed872c6334185fdebf3d60b2aa219fc1fe7516 (patch)
tree12e8c60e602df8f5c29d00e701eab0a16ede9847 /x11-plugins
parentmedia-plugins/kodi-pvr-nextpvr: 3.3.21 version bump (diff)
downloadgentoo-17ed872c6334185fdebf3d60b2aa219fc1fe7516.tar.gz
gentoo-17ed872c6334185fdebf3d60b2aa219fc1fe7516.tar.bz2
gentoo-17ed872c6334185fdebf3d60b2aa219fc1fe7516.zip
*/*: drop last-rited py2 packages
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/purple-plugin_pack/Manifest1
-rw-r--r--x11-plugins/purple-plugin_pack/metadata.xml12
-rw-r--r--x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild73
3 files changed, 0 insertions, 86 deletions
diff --git a/x11-plugins/purple-plugin_pack/Manifest b/x11-plugins/purple-plugin_pack/Manifest
deleted file mode 100644
index 2c56c8fc066c..000000000000
--- a/x11-plugins/purple-plugin_pack/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST purple-plugin-pack-2.7.0.tar.bz2 761618 BLAKE2B 29508a18eda2dab9b9dbb9af5a4ea456f79fe97259afc86a1131370b4b90d5544d8537d8aa2738823c1455632318812478ffeb3583490b041b82e6e631175748 SHA512 fffe1b8c38bff9ce88ae26426110923cc4722bf77fe59f6cf1123931558b06d830a842a6fe4d4f47295beec12f82cf5c25ac03d84944bb2629423ebac4399caf
diff --git a/x11-plugins/purple-plugin_pack/metadata.xml b/x11-plugins/purple-plugin_pack/metadata.xml
deleted file mode 100644
index 2ac47f283421..000000000000
--- a/x11-plugins/purple-plugin_pack/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="talkfilters">Enable support for
- <pkg>app-text/talkfilters</pkg></flag>
- </use>
- <upstream>
- <remote-id type="bitbucket">rekkanoryo/purple-plugin-pack</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild b/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild
deleted file mode 100644
index 0bfcbcf69646..000000000000
--- a/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1
-
-MY_PN=${PN/_/-}
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="A package with many different plugins for pidgin and libpurple"
-HOMEPAGE="https://bitbucket.org/rekkanoryo/purple-plugin-pack/"
-SRC_URI="https://bitbucket.org/rekkanoryo/${MY_PN}/downloads/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="debug gtk ncurses spell talkfilters"
-
-RDEPEND="
- dev-libs/json-glib
- net-im/pidgin[gtk?,ncurses?]
- talkfilters? ( app-text/talkfilters )
- spell? ( app-text/gtkspell:2 )
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
- sed -e '/CFLAGS=/{s| -g3||}' -i configure || die
-}
-
-list_plugins_dep() {
- local dependency=${1}
- grep -EH "depends.*$dependency" */plugins.cfg | sed 's:/.*::'
-}
-
-src_configure() {
- local plugins=""
-
- # list all plugins, then pull DISABLED_PLUGINS with the ones we don't need
- plugins="$(${EPYTHON} plugin_pack.py -d dist_dirs)"
- einfo "List of all possible plugins:"
- einfo "${plugins}"
-
- eval DISABLED_PLUGINS="\$${PN//[^a-z]/_}_DISABLED_PLUGINS"
- # disable known broken plugins
- DISABLED_PLUGINS+=" schedule findip xmmsremote"
- use gtk || DISABLED_PLUGINS+=" $(list_plugins_dep pidgin)"
- use ncurses || DISABLED_PLUGINS+=" $(list_plugins_dep finch)"
- use spell || DISABLED_PLUGINS+=" $(list_plugins_dep gtkspell)"
- use talkfilters || DISABLED_PLUGINS+=" $(list_plugins_dep talkfiltersbin)"
-
- for plug in ${DISABLED_PLUGINS}; do
- plugins="${plugins//${plug}}"
- done
-
- plugins="$(echo ${plugins} | sed 's:[ \t]\+:,:g;s:,$::;s:^,::')"
-
- econf \
- --with-plugins="${plugins}" \
- $(use_enable debug)
-}
-
-pkg_preinst() {
- elog "Note: if you want to disable some plugins in pack, define"
- elog "${PN//[^a-z]/_}_DISABLED_PLUGINS with a list of plugins to"
- elog "skip during install (for list see einfo in build output)."
-}