summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 10:01:23 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:58 +0300
commit184941c89e405cdc7c302779a45a4b27c0f51705 (patch)
treeca72ca9b13af5eeb94d1fcdddbb51c2b8bc67707 /x11-plugins
parentx11-misc/xxkb: fix build with -native-symlinks (diff)
downloadgentoo-184941c89e405cdc7c302779a45a4b27c0f51705.tar.gz
gentoo-184941c89e405cdc7c302779a45a4b27c0f51705.tar.bz2
gentoo-184941c89e405cdc7c302779a45a4b27c0f51705.zip
x11-plugins/wmnet: fix build with -native-symlinks
Also swapped DEPEND with BDEPEND to put imake in the right block. Closes: https://bugs.gentoo.org/726238 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmnet/wmnet-1.06-r2.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/x11-plugins/wmnet/wmnet-1.06-r2.ebuild b/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
index 21b7b7b3f0d1..df7520120959 100644
--- a/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
+++ b/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="WMnet is a dock.app network monitor"
HOMEPAGE="https://www.dockapps.net/wmnet"
SRC_URI="https://www.dockapps.net/download/${P}.tar.gz
@@ -15,16 +17,24 @@ IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXext"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
x11-base/xorg-proto
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
app-text/rman"
PATCHES=( "${WORKDIR}"/${P}-misc.patch )
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die "xmkmf failed"
+}
+
src_compile() {
- xmkmf || die "xmkmf failed."
- emake CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}"
+ emake \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ LDOPTIONS="${LDFLAGS}"
}
src_install() {