summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-20 21:31:19 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-06-26 23:53:05 +0200
commit254a25431ac601a33b8470bc92894fbe2ad1908f (patch)
tree8df1f70fd2753a9b7507773bb44e3f07c6d1dadd /x11-plugins
parentx11-plugins/bfm: EAPI7, improve ebuild (diff)
downloadgentoo-254a25431ac601a33b8470bc92894fbe2ad1908f.tar.gz
gentoo-254a25431ac601a33b8470bc92894fbe2ad1908f.tar.bz2
gentoo-254a25431ac601a33b8470bc92894fbe2ad1908f.zip
x11-plugins/bubblemon: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild39
-rw-r--r--x11-plugins/bubblemon/files/bubblemon-1.46-asneeded.patch4
-rw-r--r--x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch8
-rw-r--r--x11-plugins/bubblemon/files/bubblemon-1.46-no_display.patch4
4 files changed, 47 insertions, 8 deletions
diff --git a/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild b/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild
new file mode 100644
index 000000000000..7650a4f7fe6c
--- /dev/null
+++ b/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A fun monitoring applet for your desktop, complete with swimming duck"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${PN}-dockapp-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}-dockapp-${PV}
+
+PATCHES=( "${FILESDIR}"/${P}-gtk.patch
+ "${FILESDIR}"/${P}-asneeded.patch
+ "${FILESDIR}"/${P}-no_display.patch )
+
+src_compile() {
+ tc-export CC
+ emake GENTOO_CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin bubblemon
+ dodoc ChangeLog README doc/Xdefaults.sample
+
+ insinto /usr/share/${PN}
+ doins misc/*.{xcf,wav}
+ exeinto /usr/share/${PN}
+ doexe misc/wakwak.sh
+}
diff --git a/x11-plugins/bubblemon/files/bubblemon-1.46-asneeded.patch b/x11-plugins/bubblemon/files/bubblemon-1.46-asneeded.patch
index 3988f3796964..15f323fc471d 100644
--- a/x11-plugins/bubblemon/files/bubblemon-1.46-asneeded.patch
+++ b/x11-plugins/bubblemon/files/bubblemon-1.46-asneeded.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -32,14 +32,12 @@
OBJS = bubblemon.o
BUBBLEMON = bubblemon
diff --git a/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch b/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch
index 3383c9f5baed..5a57624061c2 100644
--- a/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch
+++ b/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch
@@ -1,5 +1,5 @@
---- bubblemon.c
-+++ bubblemon.c
+--- a/bubblemon.c
++++ b/bubblemon.c
@@ -58,6 +58,7 @@
#include <gdk/gdk.h>
#include <gdk/gdkx.h>
@@ -33,8 +33,8 @@
#ifdef KDE_DOCKAPP
/* makes the dockapp visible inside KDE wm */
gdk_window_show(bm.iconwin);
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -11,30 +11,49 @@
# no user serviceable parts below
diff --git a/x11-plugins/bubblemon/files/bubblemon-1.46-no_display.patch b/x11-plugins/bubblemon/files/bubblemon-1.46-no_display.patch
index f50d4f50d5ec..3d52cbb43c06 100644
--- a/x11-plugins/bubblemon/files/bubblemon-1.46-no_display.patch
+++ b/x11-plugins/bubblemon/files/bubblemon-1.46-no_display.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/310399
---- bubblemon.c
-+++ bubblemon.c
+--- a/bubblemon.c
++++ b/bubblemon.c
@@ -44,7 +44,7 @@
*/
#define _GNU_SOURCE