summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-08-28 14:46:29 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2015-08-28 15:04:52 +0200
commit36076f55804fbd5d8f6bb3c00c1c9a7e81f776fe (patch)
tree187df78968d3e3bfe06ae52b5915778e9bb2cff5 /x11-plugins
parentapp-shells/hstr: New package, ebuild written by me for monsieurp (diff)
downloadgentoo-36076f55804fbd5d8f6bb3c00c1c9a7e81f776fe.tar.gz
gentoo-36076f55804fbd5d8f6bb3c00c1c9a7e81f776fe.tar.bz2
gentoo-36076f55804fbd5d8f6bb3c00c1c9a7e81f776fe.zip
x11-plugins/wmSun: version bump with new homepage, ebuild cleanup
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmSun/Manifest3
-rw-r--r--x11-plugins/wmSun/wmSun-1.05.ebuild35
2 files changed, 37 insertions, 1 deletions
diff --git a/x11-plugins/wmSun/Manifest b/x11-plugins/wmSun/Manifest
index 4f82abb7f732..7bfeae4b09d0 100644
--- a/x11-plugins/wmSun/Manifest
+++ b/x11-plugins/wmSun/Manifest
@@ -1 +1,2 @@
-DIST wmSun-1.03.tar.gz 49744 RMD160 9c3bb5e35107d5ed74d0da329495beb7b0cfbff9 SHA1 e9933d84db322631f331c432ee15d4fe4decd707 SHA256 a46e11680d4625589d4d91030e17916c02405451e60d366340668a01597c4ea2
+DIST wmSun-1.03.tar.gz 49744 SHA256 a46e11680d4625589d4d91030e17916c02405451e60d366340668a01597c4ea2
+DIST wmsun-1.05.tar.gz 20680 SHA256 c70429aa8c201f3135bcea1c6ab441d3441bda399d8766824b9e506e9c85db69 SHA512 baa610db04ba67ca09112765e28c0fa945a98a61b642925dbaaa56a5b3e7da7424d8dd15097dcec932e3b603219d1f8806c0e50c025370226a157791f16911da WHIRLPOOL 2002a90c39369fec6a5567e32c4445d50f9fc5b5b07b70a2de6bb7f720ea68480249587346a519316dc96925b794273d9662f72815d7ab04cc8e748e5bc3244c
diff --git a/x11-plugins/wmSun/wmSun-1.05.ebuild b/x11-plugins/wmSun/wmSun-1.05.ebuild
new file mode 100644
index 000000000000..b84ab08da695
--- /dev/null
+++ b/x11-plugins/wmSun/wmSun-1.05.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+MY_P=${P/S/s}
+DESCRIPTION="dockapp which displays the rise/set time of the sun"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmsun"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README {BUGS,TODO}
+}