summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-12-05 15:39:40 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-12-05 16:10:53 +0100
commit4c3b6e13a37126323b908056030f3141c254937e (patch)
treebe80c519b090213feb85bd9a317be24b5c1f186d /x11-plugins
parentx11-plugins/wmclock: update SRC_URI (diff)
downloadgentoo-4c3b6e13a37126323b908056030f3141c254937e.tar.gz
gentoo-4c3b6e13a37126323b908056030f3141c254937e.tar.bz2
gentoo-4c3b6e13a37126323b908056030f3141c254937e.zip
x11-plugins/wmgtemp: drop old
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmgtemp/Manifest1
-rw-r--r--x11-plugins/wmgtemp/files/wmgtemp-1.0-list.patch127
-rw-r--r--x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild42
3 files changed, 0 insertions, 170 deletions
diff --git a/x11-plugins/wmgtemp/Manifest b/x11-plugins/wmgtemp/Manifest
index 53885d62c2d8..15ac5da95937 100644
--- a/x11-plugins/wmgtemp/Manifest
+++ b/x11-plugins/wmgtemp/Manifest
@@ -1,2 +1 @@
-DIST wmgtemp-1.0.tar.bz2 21090 SHA256 3de2e15358695ce6b9c8f2d4aae33730b90085f31ff3cd7d01647d76370c45d4 SHA512 d174eda017131bee0b96c795acd7146835dfea89df61fb1e8cd3105566372caef817b1a9bb1d12691a69024df303d78a43ca720b3fb84473bfa19d863b53e7c4 WHIRLPOOL c88cefbd5c565daba8254616fd6236423301af7313df7fb4a14fa3f1b7799b17baf94b118707a627cb244470ad117b702efeed0822fcfa55fab8c0af2704dc16
DIST wmgtemp-1.2.tar.gz 96949 SHA256 dabf70bfaa11c35ec630b1e5d7455570165c937bfe826a3b4d1278d21f0ff6cb SHA512 ab76eabb5459b6a8dde28c23b8c8d39587e7874daaf368afcbe7aabe57ce499285d4151b53afa8295991742c481ca18617e71107ae264c05ab28b24b67c00b9b WHIRLPOOL f96660d1f77e3a5d1e71b9bd4808b8aeca0d3a2747257d5306a5d0a9a6b7c3f78c1bd7447b406943dc25dfb4c7e544437c717d597cae589e0aa420c01f8ce562
diff --git a/x11-plugins/wmgtemp/files/wmgtemp-1.0-list.patch b/x11-plugins/wmgtemp/files/wmgtemp-1.0-list.patch
deleted file mode 100644
index 54a2eb2c2887..000000000000
--- a/x11-plugins/wmgtemp/files/wmgtemp-1.0-list.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-diff -Naur src/wmgeneral.orig/list.c src/wmgeneral/list.c
---- src/wmgeneral.orig/list.c 2016-01-04 13:10:41.091981064 +0100
-+++ src/wmgeneral/list.c 2016-01-04 13:10:56.428986326 +0100
-@@ -38,7 +38,7 @@
-
- /* Return a cons cell produced from (head . tail) */
-
--INLINE LinkedList*
-+LinkedList*
- list_cons(void* head, LinkedList* tail)
- {
- LinkedList* cell;
-@@ -51,7 +51,7 @@
-
- /* Return the length of a list, list_length(NULL) returns zero */
-
--INLINE int
-+int
- list_length(LinkedList* list)
- {
- int i = 0;
-@@ -66,7 +66,7 @@
- /* Return the Nth element of LIST, where N count from zero. If N
- larger than the list length, NULL is returned */
-
--INLINE void*
-+void*
- list_nth(int index, LinkedList* list)
- {
- while(index-- != 0)
-@@ -81,7 +81,7 @@
-
- /* Remove the element at the head by replacing it by its successor */
-
--INLINE void
-+void
- list_remove_head(LinkedList** list)
- {
- if (!*list) return;
-@@ -101,7 +101,7 @@
-
- /* Remove the element with `car' set to ELEMENT */
- /*
--INLINE void
-+void
- list_remove_elem(LinkedList** list, void* elem)
- {
- while (*list)
-@@ -112,7 +112,7 @@
- }
- }*/
-
--INLINE LinkedList *
-+LinkedList *
- list_remove_elem(LinkedList* list, void* elem)
- {
- LinkedList *tmp;
-@@ -132,7 +132,7 @@
-
- /* Return element that has ELEM as car */
-
--INLINE LinkedList*
-+LinkedList*
- list_find(LinkedList* list, void* elem)
- {
- while(list)
-@@ -146,7 +146,7 @@
-
- /* Free list (backwards recursive) */
-
--INLINE void
-+void
- list_free(LinkedList* list)
- {
- if(list)
-@@ -158,7 +158,7 @@
-
- /* Map FUNCTION over all elements in LIST */
-
--INLINE void
-+void
- list_mapcar(LinkedList* list, void(*function)(void*))
- {
- while(list)
-diff -Naur src/wmgeneral.orig/list.h src/wmgeneral/list.h
---- src/wmgeneral.orig/list.h 2016-01-04 13:10:41.091981064 +0100
-+++ src/wmgeneral/list.h 2016-01-04 13:10:42.883981679 +0100
-@@ -29,31 +29,25 @@
- #ifndef __LIST_H_
- #define __LIST_H_
-
--#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
--# define INLINE inline
--#else
--# define INLINE
--#endif
--
- typedef struct LinkedList {
- void *head;
- struct LinkedList *tail;
- } LinkedList;
-
--INLINE LinkedList* list_cons(void* head, LinkedList* tail);
-+LinkedList* list_cons(void* head, LinkedList* tail);
-
--INLINE int list_length(LinkedList* list);
-+int list_length(LinkedList* list);
-
--INLINE void* list_nth(int index, LinkedList* list);
-+void* list_nth(int index, LinkedList* list);
-
--INLINE void list_remove_head(LinkedList** list);
-+void list_remove_head(LinkedList** list);
-
--INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
-+LinkedList *list_remove_elem(LinkedList* list, void* elem);
-
--INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
-+void list_mapcar(LinkedList* list, void(*function)(void*));
-
--INLINE LinkedList*list_find(LinkedList* list, void* elem);
-+LinkedList*list_find(LinkedList* list, void* elem);
-
--INLINE void list_free(LinkedList* list);
-+void list_free(LinkedList* list);
-
- #endif
diff --git a/x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild b/x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild
deleted file mode 100644
index 0e7ce1d8bbf7..000000000000
--- a/x11-plugins/wmgtemp/wmgtemp-1.0-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils toolchain-funcs
-
-DESCRIPTION="CPU and SYS temperature dockapp"
-HOMEPAGE="http://www.fluxcode.net"
-SRC_URI="http://www.fluxcode.net/${P}.tar.bz2"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXpm"
-DEPEND="${RDEPEND}
- x11-proto/xextproto
- =sys-apps/lm_sensors-3*
- >=sys-apps/sed-4"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-list.patch
-
- sed -i -e "s:-Wall -g:\$(CFLAGS):" src/Makefile || die "sed failed."
-
- #Honour Gentoo LDFLAGS, rationalizing Makefile - see bug #337411.
- sed -i -e "s:LDFLAGS =:LIBS =:" src/Makefile || die "sed failed."
- sed -i -e "s:\$(LDFLAGS) -o \$(BINARY):\$(LDFLAGS) -o \$(BINARY) \$(LIBS):" src/Makefile || die "sed failed."
-}
-
-src_compile() {
- emake CC=$(tc-getCC)
-}
-
-src_install() {
- dodoc BUGS CREDITS README TODO
- dobin src/wmgtemp
- doman wmgtemp.1
-}