summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-07-09 14:16:04 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-07-09 17:40:52 +0200
commit58a738286839e5ec78f0015e47ca5413be94d35d (patch)
treecc46009c3489e69697bf1fcf4b68f717849973dd /x11-plugins
parentx11-plugins/wmpager: respect CC (diff)
downloadgentoo-58a738286839e5ec78f0015e47ca5413be94d35d.tar.gz
gentoo-58a738286839e5ec78f0015e47ca5413be94d35d.tar.bz2
gentoo-58a738286839e5ec78f0015e47ca5413be94d35d.zip
x11-plugins/wmgrabimage: respect CC
Closes: https://bugs.gentoo.org/726260 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
index b1d7ff43dabc..126ad0294ba9 100644
--- a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
+++ b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop
+inherit desktop toolchain-funcs
MY_PN=${PN/grabi/GrabI}
@@ -39,7 +39,7 @@ src_prepare() {
src_compile() {
emake clean
- emake CFLAGS="${CFLAGS} -Wall" SYSTEM="${LDFLAGS}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall" SYSTEM="${LDFLAGS}"
}
src_install() {